This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 7 voices.

Last updated by Marco 2 years, 6 months ago.

Assigned support staff: Bernat Torras.

Author Posts
January 26, 2017 at 11:35 am #1191384

Marco

I am trying to:
Sincronize a menu that contains a CPT archive page

URL of (my) website where problem appears:
Any website

I expected to see:
Correct sync (like when syncing posts or taxonomy terms)

Instead, I got:
Not a correct sync

Steps to duplicate the issue:
Add a CPT archive page to a menu, using the "View all" > "All ..." option.
Try to sync the menu.

You can see an example in my screenshots:
- There's a link to the "Projects / Projectos" archive page on both menus
- There's several custom taxonomy terms under that archive link
- The archive page is ingored when syncing
- The taxonomy terms bellow it are not ignored but are moved in the menu position because it's parent "does not exist"

January 26, 2017 at 1:01 pm #1191480

Denise

Hi Marco,

I'll help you with this.

1. How did you create the CPT? Is it created by your theme? Are you able to access the CPT archive page translation on the front-end?

2. Please add your WPML debug information below.

3. Please make sure your system meets the minimum requirements. https://wpml.org/home/minimum-requirements/

4. Please back-up your database and then go to WPML - Support - Troubleshooting, and click "Set Language Information"

Thanks,
Denise

January 26, 2017 at 1:32 pm #1191513

Marco

1. The CPT is created by me, on my custom made theme:
http://pastebin.com/S2wgEPHg

2. Done

3. It does...

4. This does not fix the bug

The bug is pretty easy to replicate.

January 30, 2017 at 1:05 pm #1193669

Bernat Torras

Hi Marco,

Thanks for reporting the issue. I confirm that this is a bug and our development team is already aware of it. By now, you should be able to manually add this item in your translated menu in Appearance>Menus.

I'll keep an eye on this issue and update you as soon as we have any news (or temporarily patch) for this.

Thanks,
Bernat

January 30, 2017 at 2:00 pm #1193754

Marco

"By now, you should be able to manually add this item in your translated menu in Appearance>Menus."

That's what I'm doing. I just thought it was important to report the bug because, in big menus, this can be really annoying.

February 15, 2017 at 1:31 pm #1209090

Marco

Is this already scheduled to be fixed?

April 21, 2017 at 3:15 pm #1259149

Nohemi

Any news about this issue ? Because the bug still present

April 24, 2017 at 5:11 am #1259869

Bernat Torras

Hi Nohemi,

This is an update just to tell you that this issue isn't fixed in latest version. Developers ara aware of this but it is not scheduled or prioritized yet. I'll update you as soon as we get any news or updates about this.

Thanks,
Bernat

April 24, 2017 at 8:18 am #1259981

Marco

Although this is not the answer I was looking for, I thank you for the update.

April 16, 2018 at 11:14 am #1643789

Christoph

What's the status of this bug? I experience the same problem and find it quite ridiculous that this issue has been marked as escalated almost a year ago and apparently nothing has happened since. Can you please provide information on when this will be fixed?

November 20, 2018 at 11:49 am #2922802

robertW-14

No news on this?

My situation is weirder where it picks up one custom post archive but not another.

It makes the menu sync useless as it trashes your menus each time you run it.
I'll probably have to uninstall that before handing the site over to the client.

January 4, 2019 at 1:55 pm #3056698

Marco

Hello?

January 29, 2019 at 8:46 am #3138670

matthewG-13

Hi,

I'm also experiencing this same issue. It's good to know that it's been escalated to WPML Developers team but is there any news on the progress of this or when a fix may be released?

Thanks.

June 12, 2019 at 8:45 am #4002043

Marco

Any news on this?