Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.86 hours from now. Thank you for your understanding.

This topic contains 3 replies, has 2 voices.

Last updated by Mateus Getulio 2 months, 2 weeks ago.

Assigned support staff: Mateus Getulio.

Author Posts
March 28, 2021 at 6:41 pm #8417653

justinK-9

Tell us what you are trying to do?

I'm trying to use automatic translator to translate all my pages, but when I go to Translation Management -> Translation Tools , in the Bulk Automatic Translation , it says "There are no jobs that you can translate automatically right now."

Is there any documentation that you are following?

https://wpml.org/documentation/automatic-translation/automatically-translating-multiple-translation-jobs-in-bulk/

Is there a similar example that we can see?

Screenshot is attached.

What is the link to your site?

hidden link

WPML tech support.PNG
March 29, 2021 at 1:42 pm #8423209

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello Justin,

Welcome to the WPML support forum.

By looking at your debug info, we see two possible culprits for this behavior. One can be that you're running an outdated version of WordPress, and the other that your website's WP Memory Limit is 40MB. Could you please correct it? First, update WP to its current version:

**IMPORTANT** - Please make a backup of the site files and database before doing the following procedure.

- Inside your wp-admin please go to Dashboard -> Updates
- Then click on the "Check again" button
- Update WordPress
- After that, please select every WPML plugin available in the list and then click on "Update Plugins".

Next, the WP memory limit needs to be increased as the minimum requirement for WPML is 128MB. Please check it out: https://wpml.org/home/minimum-requirements/

- Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Paste it just before:

/* That's all, stop editing! Happy blogging. */

- In this same file, could you please activate the debug mode so we can take a better look if the problem is not solved? After the code above, add this one:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
  
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
  
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );
  
// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

Please check the following links to read more about debugging with WordPress.
- https://codex.wordpress.org/Debugging_in_WordPress
- https://codex.wordpress.org/Debugging_in_WordPress#Example_wp-config.php_for_Debugging

After adding the code above, please try to reproduce the issue again and check if you'll find a debug.log file inside the wp-content folder.

If you locate it there, please send us the last lines here in the ticket.

Thank you, have a great day.
Mateus.

March 29, 2021 at 4:56 pm #8424501

justinK-9

Hi, I did all updates, and it's still not working.

March 29, 2021 at 6:54 pm #8424973

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

In this case, a manual reinstall of the WPML plugins can solve the issue. Could you please give it a try on your end? Just follow these instructions:

- Backup your site and database
- Deactivate all core WPML plugins (WPML, String Translation, Translation Management and Media Translation)
- Login via FTP to your wp-content/plugins/ folder
- Delete all WPML folders
- Go to http://wpml.org/my-account/downloads/ and download the latest WPML Multilingual CMS Plugin, then extract it
- Upload the plugin via FTP to wp-content/plugins/ folder
(alternatively you could upload the .zip folder using Dashboard > Plugins > new > upload)
- Activate the WPML plugin via WP Dashboard > plugins
- Complete the setup, if needed
- Register WPML for your site (at the end of setup, click on the "generate key" button)
- Navigate to Dashboard > Plugins and locate WPML Multilingual CMS
- Click on the blue link that says "Registered"
- Download and activate all needed WPML addon plugins

Check if the issue persists. If so, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.