Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 23 replies, has 4 voices.

Last updated by FilippoZ1 2 years, 1 month ago.

Assigned support staff: Bruno.

Author Posts
September 11, 2017 at 2:51 pm #1367564

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thanks for the feedback. I'll forward your topic again to our compatibility team to check the problem. I'll contact you soon.

Thank you.

September 27, 2017 at 9:17 am #1384620

FilippoZ1

Hello,
sorry to insist, but I need to know if you have any update on this matter.

I keep updating WPML, and then I try again to update bundle product translations to see if there's been a fix, but issue is still there.

October 2, 2017 at 1:08 pm #1388940

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Our 2nd tier support responded by suggesting you to follow the steps below:

- Instead of translating content using the native WooCommerce interface, translate this using the WPML Translation Editor interface.
- Click on the WooCommerce > WooCommerce Multilingual > Settings
- Select the "WPML Translation Editor" option
- Click on the "Save changes" button
- Click to edit the desired product (for example: "Tagliatelle al Tartufo Bianco + Crema di Porcini e Tartufo Bianco")
- Click on the "Update" button to update the original product
- Click to edit the translation
- Select the "La traduzione è stata completata" option and click on the "Save & Close" button

By following these steps, this should work correctly. I have not been able to test this in your testing environment as I no longer have access.

In my test environment, however, this worked correctly. By following the steps above, the product will be synchronized as expected and the dropdown is not displayed on the bundle product.

After following these steps, please let me know if the problem is fixed.

Thank you.

October 5, 2017 at 12:58 pm #1392503

FilippoZ1

I've always used only the WC Multilingual interface.
Also because it is not possibile to add translations using standard WC interface (it's full of WPML locks on fields).

From what I'm seeing, the filtered variation is not the ony data not being copied from original.
Even the % discount applied is not translated... or not working.

Please can you have someone of the 2nd tier support having a look at website?

These are the original products: hidden link
These are translated bundles: hidden link

if you need access please enable hidden field to post credentials

October 5, 2017 at 2:32 pm #1392648

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

After you've changed and saved changes to the original language products, did you save the product translations too?

I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

October 13, 2017 at 10:56 am #1400178

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Bruno is currently offline

I have tried accesing your site with the credentials above but i am not able to get past through the htaccess protection

I have tried the user/pass combo provided but i was not succesfull.

If possible please verify its working and share with me again

i have enabled the private field reply

Thank you !

October 14, 2017 at 5:47 pm #1401051

FilippoZ1

Hello Bobby,
I updated the previous post, posting working (just tried) credentials for htaccess protection.

Mind that it is possible that they are asked more than once before you can actually see the site: there's redirection from http to https in htaccess, and that you could be forced to accept an unverified certificate because of that.

October 16, 2017 at 9:56 pm #1402708

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. I contacted 2nd tier support and when they answer me I'll keep you in touch.

Thank you.

December 10, 2017 at 2:40 pm #1453643

FilippoZ1

Hello
a lot of time has passed, still nothing?

I still need Bundle products to work properly in other languages...