This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 23 replies, has 2 voices.

Last updated by ryanW-5 8 months, 2 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
July 30, 2019 at 7:20 am #4305215

ryanW-5

How long can I get it ? my customer wait for it.
Or how can resolve it customized?

July 30, 2019 at 8:53 am #4305883

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

The only workaround I am aware of what would this one:
https://wpml.org/forums/topic/button-link-option-display-error-after-copy-to-other-language/#post-4190819

"Once you choose to "translate independently", you should be able to modify these links as you wish."

So changing these directly on the translated/duplicated pages to proper values, I have no other ideas.

Regards,
Bruno Kos

July 30, 2019 at 10:18 am #4306865

ryanW-5

We still need a real solution, How long can I get it ? Thank you.

July 30, 2019 at 10:27 am #4306903

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Compatibility team has their own queue of resolving tickets and I have very minimal impact on it. I did ping them, though, but it does not guarantee that it will get priority over other tickets.

I will keep you posted!

Regards,
Bruno Kos

July 30, 2019 at 1:01 pm #4307801

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

The news from the compatibility team is the following: "The issue is coming from the theme and the fix should be done by them (to use one of WPML hooks)".

We have reached the theme authors, but we suggest you do this as well, it may help you get the issue resolved sooner. We have no effect on theme/plugin developers and their schedules, though.

Regards,
Bruno Kos

July 31, 2019 at 3:37 am #4311383

ryanW-5

Thank you.

I already create a ticket on enfold.

hidden link

July 31, 2019 at 8:47 am #4313029

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Ok, thank you for the confirmation.

Regards,
Bruno Kos

August 1, 2019 at 5:20 am #4318809

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you try the following?

Go to:

\enfold\config-templatebuilder\avia-template-builder\php\html-helper.class.php

Find:

$selected = ( ( $new_std[0] == $post_type ) && isset( $new_std[1] ) ) ? $new_std[1] : 0;

And add this after it:

$selected = apply_filters('wpml_object_id', $selected, $new_std[0], true );

Please test then and let me know if it works!

Regards,
Bruno Kos

September 16, 2019 at 9:15 am #4577821

ryanW-5

Thank you very much,
it is run ok in enfold 4.5.7.