This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Andreas W. 6 months, 3 weeks ago.

Assigned support staff: Andreas W..

Author Posts
March 25, 2019 at 9:07 pm #3458139

tomasf-2

Hello,

I already translate the "Booking URL" of my website with string translation, but it doesn't work.

This is the proper urls:

hidden link (spanish)
hidden link (English)
hidden link (german)

I already contact with theme support, but they told me that it is a WPML issue.

Waiting your reply,
Thank you in advance,
Regards,

March 25, 2019 at 9:51 pm #3458345

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

If the theme options are translated on String Translation and do not appear on frontend if might have various reasons. It could be that the theme is not compatible, which we could test on a new installation.

Please add the theme to the following test site:
hidden link

Further, the reaosn could be the current PHP configuration. You did not provide your debug WPML information this is why I will leave you some recommendations.

Could you please update WPML and its add-ons to the latest version
and let us know if the issue persists? Before doing it, please create a reliable backup of your site.

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us:
http://wpml.org/faq/provide-debug-information-faster-support/

WP MEMORY LIMIT:

Could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.

Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and not other plugins installed.

Then, if the issue might not be theme related or solved do to PHP configuration changes it might be that another plugin is causing the issue. In this case we would need to take a closer look at your website.

Kind regards
Andreas

March 27, 2019 at 10:24 am #3469523

tomasf-2

Hello,

I already make the changes that you requested.

Please let me know if you need something else,
Regards,

March 27, 2019 at 10:25 am #3469577

tomasf-2

Another pic

March 27, 2019 at 6:38 pm #3474833

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

Thank you for your message.

Please also change the value of "maxInputVars" inside of your php.ini file. You are currently using a value of 1000. I would recommend you to change this setting to at least 3000.
You can find the php.ini file on your server inside the folder for your currently used PHP version 7.1.27.

In case of any doubt please contact your hosting provides and ask for assistance.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Please also add the theme to the following test site:
hidden link

Kind regards
Andreas

April 1, 2019 at 5:32 pm #3510367

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I was able to add the string for the header link image (Booking) from the admin texts of string translation.

I see you used here an external URL that is not existing on your WP-admin section for pages. For now the booking link will show the same page for each user. As this URL does not include language by directory or as parameter, WPML will not be able to redirect the correct language.

Kind regards
Andreas

April 2, 2019 at 10:38 am #3516127

tomasf-2

Hello Andreas,

I checked but the button is not translated.

1.) The theme option ID is "top-right-button-url"

2.) The theme options use the "Redux Framework" (a widely used theme options framework for WordPress)

Waiting your reply.
Regards,

April 2, 2019 at 11:11 am #3516375

tomasf-2

I Contact with the theme support and they told me:

"In your screenshot the "Domain" is "page-builder-shortcode-strings-1352" and the "Name" is blank.

This is incorrect.

The "Domain" should be "admin_texts_sohohotel_data" and the "Name" should be "[sohohotel_data]top-right-button-url".

So please contact WPML support and ask them to translate the correct option.

April 2, 2019 at 4:06 pm #3519039

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

It seems our last messages overlapped.

The header image for the external booking page is translated on string translation. (see sreenshot)

As you refer to an external website that is not set to language by directory or by parameter it is not possible for WPML to link to a valid language content. All languages on your external page share the same URL. You will need to declare a directory or a parameter on the URL for each language.

Let me know if this clarified your question.

Kind regards
Andreas