Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 41 replies, has 2 voices.

Last updated by Paola Mendiburu 2 months, 1 week ago.

Assigned support staff: Paola Mendiburu.

Author Posts
January 14, 2021 at 1:30 pm #7844739

clausR-2

Hej Paula,

I just found out another thing. Might be related. Might not, but still a major issue.
It seems that the WPML plugin are really slowing down the Elementor Editor.
If you try and edit the page "Frontpage" then it can't and the page stops reponding.

I've tried turning off plugin one by one and it wasen't untill the WPML plugins where off that the elementor editor loaded normally again. You should be able to see this issue as well in the copied site you got.

January 14, 2021 at 3:28 pm #7846243

Paola Mendiburu
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Hi there,

May be this one is related to this errata but I think they are different problems
https://wpml.org/errata/elementor-editor-does-not-load-due-to-a-rest-api-error/

Regarding the link problem I will pass it to a second tier.

I will let you know when I have news.

Kind regards,

Paola

January 14, 2021 at 3:47 pm #7846393

clausR-2

Hej Paula,

Thanks for the article. That did the trick it seems 🙂 Do you expect this fix to be apart of next release? because I guess it would get overwritten then and become an issue once more.

January 18, 2021 at 10:13 am #7867207

Paola Mendiburu
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

It should be fixed on next release.

Also regarding the link problem it is related that you are using as permalink the following structure: /%category%/%postname%/

This is also a bug that is going to be fixed on 4.4.9 version.

In the meantime you can use normal url instead of internal url

Sorry for that.

Kind regards,

Paola

January 18, 2021 at 12:35 pm #7868701

clausR-2

Hi Paula,

Do you have any idea about the timeframe for this new release ? 🙂

January 20, 2021 at 11:23 am #7886191

clausR-2

Hi Paula,

The WPML Plugin still seam to create problem for Elementor editor to load, with the fix you provided in the article. Can you try opening the Elementor page called "Frontpage". I would load fully at all, so you are uanable to edit amnything.

January 21, 2021 at 12:07 pm #7896251

clausR-2

Hi Paula,

Have you had time to look at my other issue and question above? 🙂

January 21, 2021 at 1:29 pm #7897335

Paola Mendiburu
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Hi there!

We have just released 4.4.9

Please update it and let me know if that fix the issue!

Kind regards,

Paola

January 21, 2021 at 1:56 pm #7897507

clausR-2

Hi Paula,

Just updated all new relaeases. The issue remains the same.

January 21, 2021 at 2:24 pm #7897727

clausR-2

And the issue with the Elementor Editor freezing when having WPML plugin enabled, is also still an issue.

January 21, 2021 at 2:44 pm #7897875

Paola Mendiburu
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Do you mean the link issue?

Let´s go one problem at a time?

January 21, 2021 at 2:56 pm #7898077

clausR-2

Both are still an issue, but yes the links issue are the most important one for us to get solved, asap.

January 25, 2021 at 7:12 am #7918269

Paola Mendiburu
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Ok.

I am working on it.

Kind regards,

Paola

January 26, 2021 at 11:04 am #7930197

Paola Mendiburu
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

So, I have escalated the problem to a second tier.

I will update you when I have news.

Kind regards,

Paola

January 27, 2021 at 9:22 am #7938451

Paola Mendiburu
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

My colleague tell me if you can disable the server side cache as maybe can be an issue related to that.

Please let me know how it goes.

Thank you,

Paola