Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 41 replies, has 2 voices.

Last updated by Paola Mendiburu 2 months ago.

Assigned support staff: Paola Mendiburu.

Author Posts
January 28, 2021 at 8:34 am #7948673

clausR-2

I tried disabling both php opcache and apache server cache. That had no result other than poor performance on the site. So that will NOT be an option.

January 28, 2021 at 11:11 am #7950435

Paola Mendiburu
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Ok, you are saying that after clearing the cache, you made a test and the issue persists right?

January 28, 2021 at 11:32 am #7950781

clausR-2

Yes

January 29, 2021 at 4:12 pm #7963581

Paola Mendiburu
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Ok I will let the second tier know.

February 2, 2021 at 3:53 pm #7989091

Paola Mendiburu
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Hi there!

The issue is escalated to our developers.

I will let you know when I have news.

Thanks.

Kind regards,

Paola

February 3, 2021 at 4:20 pm #7998671

Paola Mendiburu
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Hi there!

The seconod tier has give me a workaround while looking for a definitive solution. The problem is related when using internal links.

So if you want to use internal links, you will need to do the following:
- Go to: wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders-elementor/src/DynamicContent/Strings.php
In the values:

const TRANSLATABLE_SETTINGS = [
		'before',
		'after',
		'fallback',
	];

- add post_id so it looks like:

	const TRANSLATABLE_SETTINGS = [
		'before',
		'after',
		'fallback',
		'post_id',
	];

- update the original page making a small change
- translate it
- Go to String Translation, and put the translated ID of the page like the attached image

Another option is to not use internal url and use it as normal links.

Kind regards,

Paola

translate-dynamic-url.png
February 5, 2021 at 7:43 am #8013433

clausR-2

I think this workaraound will only make things more complex. Please note that this hasn't always been an issue, so it has worked before, as you've also seen.
So in my mind, something changed after an update.

February 5, 2021 at 9:24 am #8014353

Paola Mendiburu
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Yes, it is a bug and it has been escalated to our developers. They were able to reproduce the problem.

While there is a permanent solution, you can use the workaorund as I told you in the previous response.

Kind regards,

Paola

April 15, 2021 at 6:44 am #8540987

clausR-2

Hi Paula,

Is there any updates to this issue. I'm not interested in using any of the workaround, in that it has worked before, but now doesn't.
We have a lot of links on the site using internal link, and it would be extremely time consuming and costly to go through all of them.

April 15, 2021 at 6:50 am #8541001

Paola Mendiburu
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Hi there!

For the moment it is only the workaround that I told you.

Sorry for that.

Paola

April 15, 2021 at 7:02 am #8541029

clausR-2

Hi Paula,

Thanks for the update. That is very unfortunate to hear.
I would appreciate some transperiancy about whether or not you intend getting the issue fixed or not within a reasonable timeframe?

April 15, 2021 at 7:20 am #8541127

Paola Mendiburu
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

What I can told you that the issue is escalated to our developers as I told you and for the moment there is only a workaround.

So in order to fix you will need to use the workaround I provide you.

There is no more information.

Kind regards,

Paola

April 15, 2021 at 7:28 am #8541205

clausR-2

Hi Paula,

That was not really an answer at all to my question.
I expected a bit better support/service than that to be honest.

April 15, 2021 at 8:05 am #8541513

Paola Mendiburu
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

We have give you a workaround so you can fix your problem.

Normally when it is escalated to developers the will release the fix in the next versions, but it has not been put in which version or when for the moment.

So I will keep you update when I have news.

Kind regards,

Paola