This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Andreas W. 4 weeks ago.

Assigned support staff: Andreas W..

Author Posts
September 9, 2019 at 8:42 am #4534749

jonathanE-10

I am trying to: Click a link displayed as a button in the 2nd language (Khmer), but the link opens the main language version of the page (English)
Link to a page where the issue can be seen: hidden link (See More >> button)
I expected to see: hidden link
Instead, I got: hidden link

September 9, 2019 at 8:43 am #4534777

jonathanE-10

Hi, I checked for redirects in cPanel and Yoast. Also cleared all caches and it's still not working.

September 9, 2019 at 4:14 pm #4538851

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

I am not understanding the issue so far. Which button exactly is not redirecting correctly? I did not see one on your provided examples.

But I can see that the following page seems not to be translated completely:

hidden link

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

September 16, 2019 at 3:12 am #4576001

jonathanE-10

Hi

I've found a workaround, but the problem is this...

I'm using Elementor Pro and when I add a button on a page which links to another page on the site, it works fine in the primary language. However, when I visit the Khmer (secondary language) version of the site and click the button, it will take me to the English version of the destination page.

To fix it I have had to load the Khmer version of the page in Elementor Pro and manually change the link behind the button to point to the Khmer version of the destination page.

Links work fine on text and images, just not on buttons. Is this an issue with my setup, or perhaps a bug in WPML?

The buttons are now fixed, however I do have a test version of the site I can fire up and give you access to if needs be.

Thanks...

Jon

September 16, 2019 at 4:58 pm #4582783

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Indeed, such issues are abel to be solved by translatin manually on the WordPress page editor.

Please provide access to the test site, as I would like to invesitgate further.

Kind regards
Andreas

September 18, 2019 at 3:02 pm #4597797

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The untranslated links refers to the page "Products & Service" -> "Products" which is not translated yet. Could you please translate the page and then translate the page including the button again.

Usually, this should solve the issue.

Let me know if you need further assistance.

Kind regards
Andreas

The topic ‘[Closed] Button redirecting to incorrect language’ is closed to new replies.