Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 3 voices.

Last updated by Bigul 7 months, 1 week ago.

Assigned support staff: Bigul.

Author Posts
October 29, 2020 at 4:33 pm #7337983

jakobV

Tell us what you are trying to do?
Trying to translate "Send Me A Message" left corner on page (CTA)

Is there any documentation that you are following?
https://wpml.org/de/forums/topic/plugin-buttonizer-and-wpml/

tried

<key name="[buttonizer_buttons][0][buttons][0]label"/>

What is the link to your site?
hidden link

October 29, 2020 at 7:36 pm #7338741

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello, welcome to the WPML support Forum!

Before your ticket is assigned to one of my colleagues, please allow me to walk you through some initial debugging steps. This will help speed up the support process.

Please check if it's possible to find it the button string on the Translate texts in admin screen page, like on this link: https://wpml.org/documentation/getting-started-guide/string-translation/#admin_texts

Please let us know if it worked for you.

October 29, 2020 at 8:56 pm #7339327

jakobV

Hi

thanks for quick reply!

I already tried it here but did not work yet. Thank you for looking further into this

Bildschirmfoto 2020-10-29 um 21.55.44.png
October 30, 2020 at 9:22 pm #7347491

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking.

Please refer to the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

November 2, 2020 at 7:16 pm #7361173

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jakob,

Thank you for the login information. The actual *Send Me A Message!* string was not included for translation. It works as expected after I added the string for translation from WPML>>String Translations>>Translate texts in admin screens screen and translate it.

Please check the attached images & documentation for more details and let me know your feedback.

https://wpml.org/documentation/getting-started-guide/string-translation/finding-strings-that-dont-appear-on-the-string-translation-page/#strings-arent-selected-for-translation

--
Thanks!

Bigul

2020-11-03_00-39-38.png
2020-11-03_00-39-24.png
2020-11-03_00-35-08.png
November 3, 2020 at 10:19 am #7365867

jakobV

Thank you Bigul, I was really blind! I understood the process, but it seems I still do something wrong. I followed your instructions to learn the translation process with the hyperlink of this same CTA Button.

admin_texts_buttonizer_buttons_published

"hidden link" to "hidden link"

But the German link still leads to the English page.

Could you provide me the missing step? Sorry for asking, you did a great job! It is me who is still struggling 😉

My best and thank you,
Jakob

Bildschirmfoto 2020-11-03 um 11.16.07.png
Bildschirmfoto 2020-11-03 um 11.12.36.png
Bildschirmfoto 2020-11-03 um 11.12.15.png
Bildschirmfoto 2020-11-03 um 11.11.33.png
November 3, 2020 at 10:52 am #7366283

jakobV

... another issue I have found:

If opening webpage in logged out or in privacy mode, the button is not translated into German. Switching between the languages leads to "English page and German button".

hidden link

- Open page logged out / in privacy mode
- switch language to German - button English
- switch language English again - button German

Thank you so much for further help!

November 3, 2020 at 11:45 am #7366851

jakobV

Update for #7366283:

- After switching language you can visit another page, then the translation of the button label seems to be correct. Is this maybe a "reload page" problem after switching?

November 4, 2020 at 10:04 am #7374855

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jakob,

Thank you for the updates. Please try the following steps after a full site backup and check is there any difference in the result.

1) Deactivate the Loco Translate plugin. Because maybe using more than one multilingual plugin on the site will make conflicts
2) Upgrade to the latest version of WPML plugins
3) Clear all types of caches, including server-side caches if any

--
Thanks!

Bigul

November 4, 2020 at 10:54 am #7375745

jakobV

Hi Bigul

thank you for your message. I deactivated loco translate, emptied all caches, updated all plugins.

the issue is still there. could you investigate why WPML has an issue here with the name & URL? thank you

- "Send Me A Message" -> "Jetzt Nachricht senden"
- hidden link -> hidden link

thank you so much
Jakob

November 5, 2020 at 8:56 am #7383609

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jakob,

Thank you for the updates. Please check the attached images. I am getting the expected results after adding the language configuration for those strings in WPML>>Settings>>Custom XML configuration.

Please check it after clearing the cache and make sure the issue is existing or not.

--
Thanks!

Bigul

2020-11-05_14-23-22.png
2020-11-05_14-20-03.png
November 5, 2020 at 10:43 am #7384897
jakobV

Hey Bigul,

thanks for the nice update and the working German link!

The only issue with WPML left is, when switching the language, the page needs to be reloaded to have the correct translation (see attachment)

any idea what causes this?
hidden link

thank you for your kind help
jakob

New threads created by Bigul and linked to this one are listed below:

https://wpml.org/forums/topic/the-page-needs-to-be-reloaded-to-have-the-correct-translation/

November 5, 2020 at 8:19 pm #7389349

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Happy to know you are getting the expected result for the button text and link now.

Please note, I have opened a new ticket for the The page needs to be reloaded to have the correct translation issue. Because as per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket. Also, it will help other users with similar problems find solutions when searching the forum. I will get back to you soon on the latest ticket. Please wait. Thank you for your understanding.

--
Thanks!

Bigul