Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by Alfredo 6 years, 3 months ago.

Assigned support staff: Sumit.

Author Posts
July 14, 2015 at 9:31 am #658718

Alfredo

I am trying to: Until today all works fine, now when i update a page i have this error
Warning: Creating default object from empty value in /home/cleanlab/public_html/sansonestore.com/wp-content/plugins/wpml-media/inc/wpml-media.class.php on line 476

Warning: Cannot modify header information - headers already sent by (output started at /home/cleanlab/public_html/sansonestore.com/wp-content/plugins/wpml-media/inc/wpml-media.class.php:476) in /home/cleanlab/public_html/sansonestore.com/wp-includes/pluggable.php on line 1196

URL of (my) website where problem appears:

I expected to see:

Instead, I got:

July 14, 2015 at 1:09 pm #658962

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thank you for contacting support forum.

You are using old versions of WPML and its addon plugins.
If you are NOT an ICanLocalize client then you can upgrade to WPML 3.2.2 and all its addon plugins to their latest version.
Please follow this article and watch the video carefully before updating https://wpml.org/2015/06/wpml-3-2-released/

NOTE:
Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Thanks

July 14, 2015 at 2:40 pm #659044

Alfredo

Hello. I have upgraded all plugins. Deactivated and deleted the pldest then uploaded the new ones.
Nothing changed. I have the same error. All works perfect if I disable WPMl Media Plugin.
Thanks

July 15, 2015 at 7:31 am #659466

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Can you please disable all plugins those are unrelated with WPML and switch to one of default themes e.g. Twenty Fifteen, Do you see the same issue ?

NOTE:
Also make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Thanks

July 15, 2015 at 9:08 am #659553

Alfredo

Hello.
I made this basic actions too. But it doesn't work yet.
I have installed Enfold tempate updated, wpml plugins all updated, Seo by Yoast updated.
The same plugins are installed on other site without problems.
I've contacted server administrators too. They have checked but said all is ok by their side to contact you cause the problem is into the wpml media plugin.
Thanks for your help.

July 15, 2015 at 10:01 am #659626

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thanks for letting me know about this.

This is common PHP warning causes by old programming style with new PHP version greater than 5.4.
But I don't see any object creation in that file (As what error says) instead I see a suspected code of line in old WPML media code.

Can you please confirm that you are using WPML media 2.1.12
If yes then I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.
Instructions to send private information are here: hidden link

Thanks

July 16, 2015 at 7:42 am #660360

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thanks for providing details but I can not login into site.
this url is hidden link is 404
Adding a screenshot.

Thanks

7-16-2015 1-09-17 PM.png
July 16, 2015 at 7:51 am #660377

Alfredo

Hello Sumit. Yesterday i have written:
"The site is on devoloping. Is not online, or better I have changed my local hosts file entries to point to the server and working on it.
These are the lines to add to hosts file:
109.73.233.128 sansonestore.com
109.73.233.128 hidden link"
If you don't add this two lines of code in your pc file host you can see the site. I'm devoloping on a server. The site online is made with Prestashop.

July 16, 2015 at 8:56 am #660447

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Yes I followed what you said. but 109.73.233.128 sansonestore.com does not work for me.
but 109.73.233.128 hidden link (with www) works.
I will respond you back once I am done with my debugging.

Thank you.

July 16, 2015 at 9:20 am #660469

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I just turn on WP_DEBUG mode and activated WPML media but I don't see any errors and warnings.
Can you please provide me a screenshot or link of this error?

Thanks

July 16, 2015 at 9:30 am #660478

Alfredo

Hello.
Yes I have the error. I was working on site and when you have turned on the plugin I have caught the error saving a page.
I can work without media plugin, but i am worried it could give problems after when i will go online.

Schermata 2015-07-16 alle 11.29.26.png
July 16, 2015 at 9:43 am #660496

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I just created this page. I did not find the error. /wp-admin/post.php?post=3905&action=edit&lang=en&admin_bar=1

I tried these steps.
- saved it many times.
- added featured images and saved it again
- created translation then saved that
- removed featured images from original post and saved the translation

Is it happening for all posts or some specific one?
Please provide me more details to reproduce this issue.

July 16, 2015 at 9:54 am #660505

Alfredo

Hello Sumit.
First to all I have to thank you very much for the attention to my problem and fantastic support.
Then...You are right. If i try to save and resave on your test page all goes right.
But if I go on page called "Home Page - Front Page" I have the error. I don't know if it is only this page (I gave worked on it last days and caught the error here).
Kindly regards,
Alfredo

July 16, 2015 at 11:34 am #660602

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Alfredo,

You are welcome 🙂

On home page "duplicate featured image" checkbox is checked. But there is no featured image assigned to that page. If you uncheck it error disappears.
But this is an issue so I tried to reproduce it on my server but i couldn't. Then I found a featured image entry is there in your DB but image is broken.

Please take a look at screenshot. And try to assign a valid image or remove it completely (assign an image then remove) and let me know do you see the same issue again?

Thanks

7-16-2015 4-56-22 PM.png
August 12, 2015 at 9:28 am #677900

Alfredo

Sorry. For the late reply. Thanks a lot for your attention and time.
Yes in this way the iusse is solved.
Have a nice day.
Reagards,
Alfredo