This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I'm having the exact same problem as I mentioned here: https://wpml.org/forums/topic/calculating-shipping-2/page/2/ Only for other products (the dog muzzles for example)

Solution: Please follow this steps: - Create a full backup of the site before making any change. - Go to Woocommerce -> Woocommerce Multilingual -> Status tab -> Fix all the errors that appeaar there. - Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link (bottom right) -> Sync all products. - Flush any cache memory that might exist.

Relevant Documentation:

This topic contains 6 replies, has 2 voices.

Last updated by Carlos Rojas 11 months, 4 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 6, 2018 at 2:23 pm #2792887

anneH-2

I'm having the exact same problem as I mentioned here: https://wpml.org/forums/topic/calculating-shipping-2/page/2/
Only for other products (the dog muzzles for example)

There is a quick solution mentioned, but I can't seem to figure out how to solve this.
If I go to WooCommerce -> WooCommerce Multilingual -> Shipping Classes I can't find a button to synchronize shipping classes...? How do I synchronize them?

October 9, 2018 at 1:05 am #2797630

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Kind regards,
Carlos

October 10, 2018 at 6:31 pm #2805428

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Please follow this steps:
- Create a full backup of the site before making any change.
- Go to Woocommerce -> Woocommerce Multilingual -> Status tab -> Fix all the errors that appeaar there.
- Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link (bottom right) -> Sync all products.
- Flush any cache memory that might exist.

Could you tell me if the issue is solved?

Best regards,
Carlos

October 14, 2018 at 7:51 am #2815102

anneH-2

If I go to Woocommerce -> Woocommerce Multilingual -> Status tab -> it shows me products I still need to translate. Most of those products I don't want on my English website so I'm not sure why I should translate over 200 products to solve this issue?

If I go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link (bottom right) I can select up to 6 options. Which options should I select?

Kind regards,
Anne

October 15, 2018 at 4:52 am #2816247

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Anne,

1.- In Woocommerce -> Woocommerce Multilingual -> Status tab -> Please fix the issues in the attached image (1.png)

2.- In Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link -> Select the options in the attached image (2.png) and sync the products.

Note: Please remember to create a full backup of the site before making any change.

Could you tell me if the issue persists after the steps above?

Best regards,
Carlos

October 24, 2018 at 8:32 am #2845315

anneH-2

Thanks, "2.- In Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link -> Select the options in the attached image (2.png) and sync the products." did the trick.

October 24, 2018 at 4:37 pm #2847307

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Anne,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos