This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: How to translate fusion Slider?

Solution: Usual method: https://wpml.org/documentation/theme-compatibility/using-wpml-with-the-avada-theme/#translating-avada-sliders

Alternative: Simply create two sliders. One for your primary language and the other one for your second language. You can just select the slider you want in your translated pages.

This topic contains 6 replies, has 2 voices.

Last updated by aislingC 1 year ago.

Assigned support staff: Riffaz.

Author Posts
October 9, 2018 at 8:46 pm

aislingC

I am trying to: to translate my homepage from Eng to French but the Fusion Slider at the top is missing

Link to a page where the issue can be seen: hidden link

I expected to see: the same slider on the French version

Instead, I got: hidden link (missing slider)

Why did this happen and how can I fix it!? Thx in advance..

October 10, 2018 at 7:27 am #2803187

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

It seems you did not translate the slider.
Please refer : https://wpml.org/documentation/theme-compatibility/using-wpml-with-the-avada-theme/#translating-avada-sliders

Basic steps:
Please go to WPML > Translation management > Multilingual content setup in the Custom post types section. Check if "Fusion Sliders" is set to "Translate". Then in the Custom fields section, check if "pyre_wooslider" is set to "Translate" too.
Does the slider options are copied to secondary language now.

Let me know if you need anything else regarding this.

Regards,
Riffaz.

October 10, 2018 at 11:56 am #2804109

aislingC

Hi Riffaz,

Thanks for the reply. I had noticed this yesterday after looking at a YT tutorial. I don't have the MULITILINGUAL CONTENT SETUP tab.. I've all the plugins activated Afaik..

October 10, 2018 at 12:23 pm #2804209

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Sorry, we've moved the option to WPML > Settings > Custom Fields Translation in the latest version.
Please check it here : hidden link and in WPML > Settings > Post Type Translation

Let me know.

Regards,

October 10, 2018 at 12:55 pm #2804280

aislingC

Thanks again.

Wooslider was set to COPY ONCE so I changed that to TRANSLATE. But see attached for status of FUSION SLIDER (which I have not changed) Should I?

The slider has not appeared. But let me know if I need to change something here too.

October 11, 2018 at 5:41 am #2806687

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Your fusion slider setting is fine. It should be able to translate.
Anyhow, double-click on the lock icon there and set select "Translatable - Use translation if available or fallback to default language" and check if you can translate it now.

if that does not work you can simply create two sliders.
One for your primary language and the other one for your second language.
You can just select the slider you want in your translated pages.
That would be easier I guess.

Let me know.

Regards,

October 11, 2018 at 7:14 am #2806896

aislingC

My issue is resolved now. Thank you!