Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by tonyL-14 3 months, 3 weeks ago.

Assigned support staff: Bobby.

Author Posts
October 23, 2019 at 10:19 am #4810001

tonyL-14

Hi there,

I have another issue, I can not enable the "One more step before you can translate on Elementor". (please find the image attached) Could you please help? I think I will need to enable this feature then send the content to Gengo for translation?

Thanks

October 24, 2019 at 6:51 am #4816357

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

Please follow the steps below and let me know your results:

1. Go to WPML->Settings->"How to translate posts and pages"
2. Select either Advanced Translation Editor or WPML's Classic Translation Editor

October 24, 2019 at 7:07 am #4816495

tonyL-14

Now the content can be synced to Gengo and get translated, but why the translated page has total different layout? I'm on Elementor.

Original page: hidden link
Translated page:hidden link

How can I fix the layout?

Thanks

October 24, 2019 at 5:05 pm #4822439

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

Please go to your page's default language and edit.

Scroll to the bottom and share a screenshot of your Custom Fields/Taxonomies with me.

Additionally, click on the top header language switcher and switch to the second language on a new tab. (dismiss the warning)

Are you able to notice any difference between styling options in the backend?

October 25, 2019 at 3:00 am #4823735

tonyL-14

Hi Bobby,

Please find the screenshot attached.

Sorry, I don't find the second language on the new tab, I have assigned a user for you, so can you login check on your own?

[removed]

Thanks

October 25, 2019 at 6:22 pm #4829345

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

If possible please review the above credentials as I am not currently able to access the site's backend.

By looking at the screenshot above i can see that a lot of elements are set to "Do not translate", what are your results if you set the to "copy" (only the ones set to "do not translate")

October 28, 2019 at 2:28 am #4835921

tonyL-14

My issue is resolved now. Thank you!