This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
We have been using Translate texts in admin screens to translate logo url into arabic, after we found logo String at Translate texts in admin screens we checked on the box and hit apply after that this massage appear {The selected strings can now be translated using the string translation screen}. we go to string translation and search about domain on it we can not find it??

Solution:
- Go to WPML -> Settings -> Custom XML Configuration.
- Add the following code:

<wpml-config>
    <admin-texts>
        <key name="anps_logo" />
        <key name="anps_front_logo" />
        <key name="anps_sticky_logo" />
        <key name="anps_sticky_transparent_logo" />
    </admin-texts>
</wpml-config>

- Go back to WPML > String Ttanslation.
- Translate your logo URL.

Relevant Documentation:
https://wpml.org/documentation/support/language-configuration-files/

This topic contains 5 replies, has 3 voices.

Last updated by riseC 1 year ago.

Assigned support staff: Andrés.

Author Posts
October 1, 2018 at 10:26 am #2777711

riseC

Hi,
we have been using Translate texts in admin screens to translate logo url into arabic, after we found logo String at Translate texts in admin screens we checked on the box and hit apply after that this massage appear {The selected strings can now be translated using the string translation screen}. we go to string translation and search about domain on it we can not find it??
please help us if you want wordpress and cpanel login ask us.
We hope you reply...

October 1, 2018 at 8:37 pm #2779462

Ricardo Alday

Hi,

Please increase the max_input_vars value in your PHP settings from 1000 to 5000 and then try to add the string from WPML -> String Translation -> "Translate texts from admin screens" again. If successful, the string will show at the beginning of the list in WPML -> String Translation.

If not, please provide access to your site using the private fields below so we can troubleshoot.

Thanks,
Ricardo

October 2, 2018 at 11:06 pm #2782953

Ricardo Alday

Thanks.
In WPML -> Settings -> Custom XML Configuration I added this code:

<wpml-config>
    <admin-texts>
        <key name="anps_logo" />
    </admin-texts>
</wpml-config>

Now you can translate the logo URL in WPML -> String Translation.

Hope that helps.

October 3, 2018 at 8:15 am #2783858

riseC

Hello.
Thank you for your kindness
We have translated logo URL into Arabic but logo image still the English logo.
We hope that you solve this issue.
Best Regards.

October 3, 2018 at 12:51 pm #2784581

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello there,

As Ricardo is not available I would like to take care of your case.

It seems your theme gives you the possibility to add your logo from different settings, that's why I have to modify your previous wpml-config.xml into:

<wpml-config>
    <admin-texts>
        <key name="anps_logo" />
        <key name="anps_front_logo" />
        <key name="anps_sticky_logo" />
        <key name="anps_sticky_transparent_logo" />
    </admin-texts>
</wpml-config>

Now, your logo displays correctly translated.

Does it solve your issue?

Regards,
Andrés

October 4, 2018 at 7:38 am #2786563

riseC

My issue is resolved now. Thank you!