This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 7.15 hours from now. Thank you for your understanding.

This topic contains 15 replies, has 2 voices.

Last updated by Roni 1 day, 5 hours ago.

Assigned support staff: Laura.

Author Posts
November 9, 2019 at 2:12 pm #4918303

Roni

I am trying to: generate .mo files

Link to a page where the issue can be seen: admin

November 9, 2019 at 6:37 pm #4918953

Roni

Does not solve the issue, already tried that...

November 9, 2019 at 7:19 pm #4919055

Roni

I am not a standard user... working with wp and wpml for ages... host my own sites...
This is issue with newest wpml version.

Tried all usual things, including deactivating all other plugins...

[debug information removed]

November 10, 2019 at 1:54 pm #4920517

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

can you try to enable the browser console and see if there are errors when you try to create the .mo files?

November 10, 2019 at 9:40 pm #4921565

Roni

POST hidden link 403 (Forbidden)

Looks like wrong url to me...

November 11, 2019 at 10:52 am #4923833

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

it seems WPML can't access that file.

Could you check with your hosting to see if it's possible to give permission to it?

November 11, 2019 at 11:00 am #4923949

Roni

directory /wp-json/ is non existent!!!

November 11, 2019 at 11:15 am #4924133

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

it's not a physical folder. If you check hidden link it exists, and it returns all your site endpoints related to REST API.

Please try contacting your hosting about this.

November 11, 2019 at 1:46 pm #4925433

Roni

I'm my host... Permissions are ok. It is working on all other sites except this one.
Trying the 403 link returns:
{"code":"rest_no_route","message":"Nije prona\u0111ena ruta sa odgovaraju\u0107im URL i metodu zahtjeva","data":{"status":404}}

November 11, 2019 at 1:56 pm #4925471

Roni

Also since this last update site is not using translations at all...

November 12, 2019 at 9:19 am #4930021

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

other clients with the same error had either bad Nginx rewrite rules or a mod_security too tight.

Can you please check this?

November 14, 2019 at 10:00 am #4945285

Roni

Is there anyone that can help?
Everything seems ok. It is working on other sites with all the same settings, versions of php and the rest... All are on same server, so I'm just lost with what is wrong here!

Even translated strings are not shown on front end!

November 15, 2019 at 12:17 pm #4953845

Roni

Migration done.

November 15, 2019 at 3:29 pm #4955289

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

in our server test the issue didn't happen - I managed to create the .mo files as soon as I accessed it, so it must be related to the server.

Can you share with me your .htaccess?

November 15, 2019 at 6:40 pm #4956209

Roni

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

<IfModule php7_module>
php_flag display_errors Off
php_value max_execution_time 180
php_value max_input_time 180
php_value max_input_vars 2000
php_value memory_limit 200M
php_value post_max_size 64M
php_value session.gc_maxlifetime 1440
php_value session.save_path "/var/cpanel/php/sessions/ea-php71"
php_value upload_max_filesize 15M
php_flag zlib.output_compression On
</IfModule>
<IfModule lsapi_module>
php_flag display_errors Off
php_value max_execution_time 180
php_value max_input_time 180
php_value max_input_vars 2000
php_value memory_limit 200M
php_value post_max_size 64M
php_value session.gc_maxlifetime 1440
php_value session.save_path "/var/cpanel/php/sessions/ea-php71"
php_value upload_max_filesize 15M
php_flag zlib.output_compression On
</IfModule>
# END cPanel-generated php ini directives, do not edit

<IfModule mod_deflate.c>

# Force compression for mangled headers.
# hidden link
<IfModule mod_setenvif.c>
<IfModule mod_headers.c>
SetEnvIfNoCase ^(Accept-EncodXng|X-cept-Encoding|X{15}|~{15}|-{15})$ ^((gzip|deflate)\s*,?\s*)+|[X~-]{4,13}$ HAVE_Accept-Encoding
RequestHeader append Accept-Encoding "gzip,deflate" env=HAVE_Accept-Encoding
</IfModule>
</IfModule>
</IFModule>

<IfModule mod_expires.c>
ExpiresActive On
ExpiresByType image/jpg "access 1 year"
ExpiresByType image/jpeg "access 1 year"
ExpiresByType image/gif "access 1 year"
ExpiresByType image/png "access 1 year"
ExpiresByType text/css "access 1 month"
ExpiresByType application/pdf "access 1 month"
ExpiresByType text/x-javascript "access 1 month"
ExpiresByType application/x-shockwave-flash "access 1 month"
ExpiresByType image/x-icon "access 1 year"
ExpiresDefault "access 1 month"
</IfModule>

Header unset ETag
FileETag None

# php -- BEGIN cPanel-generated handler, do not edit
# Set the “ea-php72” package as the default “PHP” programming language.
<IfModule mime_module>
AddHandler application/x-httpd-ea-php72 .php .php7 .phtml
</IfModule>
# php -- END cPanel-generated handler, do not edit