This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by silvinaS 2 months, 1 week ago.

Assigned support staff: Bruno.

Author Posts
August 14, 2019 at 7:30 pm #4397185

silvinaS

Hello,

I can not install wpml cms, (Tried to lastest versions).
I am using latest wordpress version and never installed another plugin to translate.

I see this when installing:

''No ha sido posible copiar el archivo. sitepress-multilingual-cms/locale/sitepress-pl_PL.mo''

And then ''plugin fatal error''.

Thanks in advance for your help

August 15, 2019 at 2:09 am #4398255

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Are you using WPML in the latest version? Did you download the plugin from the downloads page (https://wpml.org/account/downloads/)?

Also, what is the complete error message being displayed? Please, could you enable debug to see if any error message is displayed? To do it, please check the steps in our documentation: http://wpml.org/documentation/support/debugging-wpml/

Then try again to check the problem. If any error message appears, please paste here in the post for me to see.

Thank you.

August 15, 2019 at 7:56 am #4399355

silvinaS

thanks for your answer

Yes, I tried to install latest version and 4.2.7.1.
Yes, I downloaded from the download page.
I can not send debug information because the plugin ist not installed.

I see ''Plugin is not installed''
No ha sido posible copiar el archivo. /var/www/vhosts/rayuelatango.com/httpdocs/wp-content/plugins/sitepress-multilingual-cms/locale/sitepress-fr_FR.mo

And If I activate the plugin I see this:
Warning: require(/var/www/vhosts/rayuelatango.com/httpdocs/wp-content/plugins/sitepress-multilingual-cms/inc/functions-helpers.php): failed to open stream: No such file or directory in /var/www/vhosts/rayuelatango.com/httpdocs/wp-content/plugins/sitepress-multilingual-cms/sitepress.php on line 46

Warning: require(/var/www/vhosts/rayuelatango.com/httpdocs/wp-content/plugins/sitepress-multilingual-cms/inc/functions-helpers.php): failed to open stream: No such file or directory in /var/www/vhosts/rayuelatango.com/httpdocs/wp-content/plugins/sitepress-multilingual-cms/sitepress.php on line 46

Fatal error: require(): Failed opening required '/var/www/vhosts/rayuelatango.com/httpdocs/wp-content/plugins/sitepress-multilingual-cms/inc/functions-helpers.php' (include_path='.:/opt/plesk/php/7.1/share/pear') in /var/www/vhosts/rayuelatango.com/httpdocs/wp-content/plugins/sitepress-multilingual-cms/sitepress.php on line 46

thank you

August 15, 2019 at 9:52 pm #4403679

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thanks for the description of the issue. As you can see from the error message, some WPML files were not copied correctly:

Warning: require(/var/www/vhosts/rayuelatango.com/httpdocs/wp-content/plugins/sitepress-multilingual-cms/inc/functions-helpers.php): failed to open stream: No such file or directory in

In the error message above, you may notice that one of these errors is that the file "functions-helpers.php" is not being found. How did you do this instance? Did you use the WordPress feature (Plugins > Add New > Upload Plugin) or did you upload the files manually with FTP?

I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

August 17, 2019 at 1:06 am #4408587

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for the credentials. When I try to access your FTP, this error message appears:

Status:	Connecting to 149.62.169.149:8443...
Status:	Connection established, waiting for welcome message...
Error:	Connection timed out after 20 seconds of inactivity
Error:	Could not connect to server
Status:	Waiting to retry...

Please, can I install the "WP File Manager" plugin (https://wordpress.org/plugins/wp-file-manager/) on your site so I can try to check why the WPML directory is not being created?

Thank you.

August 17, 2019 at 11:44 am #4409953

silvinaS

Hello Bruno,

Yes, you can install the manager file plugin. I am trying to solve ftp connection error with my hosting support.

Thanks for your help

August 17, 2019 at 2:01 pm #4410183

silvinaS

Hello,

I got new ftp credentials, they work now. Please, send me a private message to send them.

Thanks

August 19, 2019 at 9:25 am #4414855

silvinaS

Hello,

It was a hosting server problem, so I solved with them.
Thanks for your help anyway.

August 19, 2019 at 9:26 am #4414857

silvinaS

My issue is resolved now. Thank you!