Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:
How to translate a string in a tab with WPML that I can't find inside WPML String Translation

Solution:
If you can't find it inside the WPML > String Translation, it might be added as admin text.

This should be the normal process to translate admin texts:
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

Sometimes, depending on the case, you will still have to do an extra step if after you find the string in admin texts panel and check the box and save it, it still doesn't show up in WPML > String Translation.

You might need to increase the max input vars to a big value like 50000.

For this, please try to set this variables in your php.ini:

max_input_vars = 50000;
suhosin.post.max_vars = 50000;
suhosin.request.max_vars = 50000;

You may need to contact your hosting provider to set them.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

After that, you should be able to find the field inside WPML > String Translation.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by emmanuelF-3 1 year, 4 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
June 9, 2019 at 2:52 pm #3983177

emmanuelF-3

Hi,

I want to translate on the English page "RESERVER UNE TABLE" by "BOOK A TABLE" but the sentence does not appear in wpml.
Thank you for telling me how to solve the problem.
Best regards
Emmanuel

hidden link
hidden link

June 10, 2019 at 9:10 am #3986063

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Emmanuel and thank you for contacting WPML Support!

I will be happy to help you with this.

The way to translate those strings really depends on how they have been implemented in the code.

1. Can you please let me know if you tried to go to WPML > String Translation and search for any of the words in those sentences?

Here is some very helpful documentation on how to use the String Translation plugin:
https://wpml.org/documentation/getting-started-guide/string-translation/

If it's not there, it could help if you scan the plugin/theme that's generating the strings and then go back to WPML > String Translation and see if the strings show up:
https://wpml.org/documentation/getting-started-guide/theme-localization/

2. If you can't find it inside the WPML > String Translation, it might be added as admin text.

This should be the normal process to translate admin texts:
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

If you still can't find it, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

June 10, 2019 at 5:14 pm #3989027

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for your response.

I am at the end of my shift at the moment but I will check this tomorrow and will get back to you with feedback.

I am leaving the ticket assigned to myself for the moment.

Kind regards,
Mihai

June 11, 2019 at 10:18 am #3994087

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for your patience.

I am attaching a screenshot so that you know where to go to enable that field.

I enabled it already (clicked the checkbox and then went down the page and saved) but it is not showing at the moment inside WPML > String Translation because we need to increase the max input vars to 25000 - currently you have them set at 2000.

For this, please try to set this variables in your php.ini:

max_input_vars = 25000;
suhosin.post.max_vars = 25000;
suhosin.request.max_vars = 25000;

You may need to contact your hosting provider to set them.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

After that, you should be able to find the field inside WPML > String Translation.

Please let me know how that goes.

I will be waiting for your response. 🙂

Kind regards,
Mihai

June 11, 2019 at 1:18 pm #3995657

emmanuelF-3

Perfect. My issue is resolved now. Thank you very much for your help.
A pleasure to have you as support at WPML !!!

Best regards,

Emmanuel