This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: How to "change" strings from original or primary language?

Solution: Please note, WPML was not created to change texts/words. It was meant to translate the words. So what we are trying is simply not a feature of WPML.

Anyhow, we can try following steps to change the strings in original or primary language. This may work depend on how the plugins/theme is built.

1. Go to WPML->Languages-> Add new language -> Add a random language 2. Then scroll down and hide this language. 3. Now go back to WPML->String Translation->Select your string -> Change language of string to the newly added hidden language. 4. Now you will have an option to “translate” it on the original language of the theme.

Yet, this is NOT a good solution, this should work by default. If not, there should be some incorrect or not standard code in the theme or plugins and WPML will not check this as it is NOT a WPML feature.

This topic contains 20 replies, has 2 voices.

Last updated by nhung-thi-thaoP 4 months, 4 weeks ago.

Assigned support staff: Riffaz.

Author Posts
May 16, 2019 at 8:53 am

nhung-thi-thaoP

Hi,

I am trying to translate some strings from original language (English), but can't make it to work.

I tried:
https://wpml.org/forums/topic/how-to-change-a-string-in-the-original-language-of-the-theme/

I am trying to translate strings from both WooTours, Ajax Search Form and WooCommerce.
I used to do it with LocoTranslate before my website was multi language, but since I installed WPML all translations were gone, so I deleted the LocoTranslate files and deactivated the plugin from my website. Now I am trying it with WPML, but I don't get it to work.

May 16, 2019 at 10:42 am #3824997

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

I checked this in a fresh installation and it works.
i changed the language of the string and translated in string translation as you see in the other ticket: hidden link and I see it changed in the primary language frontend: hidden link

You can try to login and check hidden link

Try to translate 'sandbox' hidden link and see.

Let me know how it goes.

Regards,
Riffaz.

May 16, 2019 at 11:17 am #3825367

nhung-thi-thaoP

Hi,

I Installed WooCommerce and WooTours on you sandbox site to check if it works, but I don't see the WooCommerce and WooTours in the Strings of WPML, so I can not check if it works translating does Strings.

But what if this would work, what does that mean for my solution? That I do a clean install?
And a clean install of what? Complete WordPress? WooCommerce? WPML?

May 16, 2019 at 2:18 pm #3826851

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

This is a text from the plugin you installed hidden link and I am able change it's language and translate it.

What are some phrases exactly you want to change?
could you please let me know by typing and show some screenshots for better understanding?

We are checking this in a sandbox because we can find the issue without inteferring your site and other third party plugins.
If everything is fine then we can guess the cause that make tyhis issue in your site.

Let me know.

Regards,

May 17, 2019 at 1:15 am #3830023

nhung-thi-thaoP

Hi,
I uploaded a screenshot.
Left is my website and right is your sandbox. Left you can see WooCommerce with 5746 available strings and Woo-Tour with 445. Right in the sandbox I don't see them.

I am a selling tours in destinations and not products in categories. So I want to translate things like:
Product = Tour
Category = Location
etc.

May 18, 2019 at 1:21 am #3837469

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

You did not scan WooTours and WooCommerce in WPML > Theme and plugin localization
I scanned them.
Changed a WooTOur word language and it changed : hidden link
You can check now in sandbox and follow the steps.

Anyhow, I see you changed WooTour 'location' language to German and translate it to English as 'Activities' : hidden link in your site.
This means you changed the English word Location to Activities in your english site.

has this been fixed or do you mean this does not work in front end.?

May 18, 2019 at 2:00 am #3837481

nhung-thi-thaoP

Hi,

Ah, I am sorry, I probably was not very clear. Yes, I am able to use the Strings to translate but it is not visible in front end.

May 19, 2019 at 5:01 am #3840665

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Product = Tour
- when I check a product in your site I see : hidden link
- so you already changed it as you want.
- or do you mean you want to change it somewhere else as well?

Category = Location
- Open your site admin panel and navigate to the Settings > Permalinks section.
- Type the needed category slug into the Category base field.
- Save the changes and refresh your site.
- if you are asking about this hidden link
- try to change the language of this hidden link and then translate it to English.

Let me know how it goes.

Regards,

May 19, 2019 at 7:03 am #3840815

nhung-thi-thaoP

Hi,

I don't mean the permalinks (they work), but the strings.

"- if you are asking about this hidden link
- try to change the language of this hidden link and then translate it to English."

I did that, but it is not visible in the front end. This is exactly the problem I am trying to fix.

You can try yourself (my website is not officially live; no visitors)

May 19, 2019 at 9:00 am #3841063

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I changed language of category text everywhere: hidden link and still no effect.
So it should be coming from theme file / hard coded.
you can simply ask your theme where does it come from or where to change this.

Or please create a simple tour like this hidden link in sand box hidden link and let me know.

Regards,

May 20, 2019 at 2:57 am #3843179

nhung-thi-thaoP

Hi,

I made a ticket with the support of my theme, I will update when I have more info from them.
I also found this documentation of my theme:
hidden link
Including this picture:
hidden link
But could not find that setting in "WPML > Translation Management > Multilingual Content Setup"
But not sure if that setting could be the fix for translating strings.

May 20, 2019 at 11:46 am #3846473

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Did you setup a tour in sandbox as I asked?

hidden link
- this one is for an older version of WPML
- your theme did not update their documents yet.
- you can find that option now in here : hidden link
- anyhow, this has nothing to do with your issue (changing a word in your default english language that comes from your theme)

Let me know.

Regards,

May 20, 2019 at 1:00 pm #3847021

nhung-thi-thaoP

Hi,

Yes, I did:
hidden link

May 20, 2019 at 1:50 pm #3847523

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for that.

On the test page I see the word "category" here only hidden link
We have to change it to 'location', right? but this is not same as your live site page where you have the "category" texts.

Regards,

May 20, 2019 at 1:56 pm #3847555

nhung-thi-thaoP

I tested with other Strings too in the sandbox, like book now, but also not seem to work.