This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by patrikP-5 2 years, 9 months ago.

Assigned support staff: David.

Author Posts
October 9, 2017 at 2:11 pm

patrikP-5

I am trying to:

I am using Zeko theme, which is officially supported by WPML.
Zeko has a front page which can show up to 4 pages in 4 panels.
These are configured in WordPress Customizer.
Unfortunately translation doesn't work here.
Of course I want to show german pages on the german front page and english pages on the english front page.
When I set panel 1 to a specific page in German language, the panel is changed for English.
I provide credentials so you can test it yourself.

Link to a page where the issue can be seen: kidshelp-kambodscha.org

October 10, 2017 at 4:08 pm #1397086

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Customizer settings have to be set in the default language when you use the customizer.

Later these settings can be translated into other languages using the String Translation add-on.

You can see the process for translating admin-texts over here:
https://wpml.org/documentation/getting-started-guide/string-translation/#admin_texts

October 10, 2017 at 6:02 pm #1397248

patrikP-5

Hi David,
thanks for your reply.
I can't find any string relating to 'panel', 'customizer' or 'zeko' or whatever.
What am I supposed to look for in the admin-texts?
Also this doesn't solve my problem that I'm not able to change panel 1 in the default language anymore.

October 11, 2017 at 10:14 am #1397875

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Ok, lets check first Panel 1.

You say its changed to english but I'm seeing german.

Make sure you use the customizer while German language is selected (German is default language).

Let me know if you find any problems with this and we'll move to the actual translation.

Thanks

October 11, 2017 at 10:55 am #1397925

patrikP-5

Hi David,
thanks for looking into this.
The problem with panel 1 is that I can't change the page.
What I did:

Set language to German in Dashboard.
Open customizer and change panel 1 page from "Unsere Arbeit" to "Über Kamodscha".
Save & Publish, close Customizer.
Open Customizer again.
It's still "Unsere Arbeit".

But if you change the language to English on the website (not in Dashboard), "Über Kambodscha" is now visible on the English front page, not on the German one.

October 11, 2017 at 3:53 pm #1398380

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I see now.

First of all, panel1 value is being lo aded from an old setting. Please go to WPML -> String Translation and select the context "admin_texts_theme_mods_zeko"

Select all the strings in this context and delete them they will be automatically registered again.

Second, with the newly registered strings, you have to provide the IDs for the translated pages, see the screenshot attached.

Let me know if you have any issues.

October 11, 2017 at 6:36 pm #1398554

patrikP-5

Thanks David, this works absolutely perfect 🙂