This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 3 weeks, 3 days ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
September 16, 2019 at 8:10 am

magnusT-4

Hello,
Thanks for great plugin.

Can you please help me get started with translation for the "home" page.

All I see when trying to translate is this,

See attached screenshot.

I tried to translate all listingPro plugin strings.

Cant see any of the ListingPro plugins "listings" or "blogg-News" on home-page.

How can I solve this?

Best,
Magnus

September 16, 2019 at 5:39 pm #4582989

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Magnus,

Thank you for contacting WPML Support. Each theme has a different approach on how the content should be translated, in your particular case you need to make sure your listing posts are translated and your blog posts as well, into details you would need to perform the following steps:

1 - Make sure your 'Listings (listing)' are set as 'Translatable' from your WordPress Dashboard > WPML > Settings > Post Types Translation settings.

See:

https://wpml.org/documentation/getting-started-guide/translating-custom-posts/

https://wpml.org/documentation/getting-started-guide/translating-post-categories-and-custom-taxonomies/

2 - Now, you should add translations for your current listing posts and categories in your WodPress Dashboard > Listings settings.

3 - You will also need to add translations for your posts in your WordPress Dashboard > Posts as they are used in the 'News & Tips' section of your homepage,

See: https://wpml.org/documentation/getting-started-guide/

4 - It is also possible to translate the theme general text such as button texts, login texts etc using the String Translation for that. See: https://wpml.org/documentation/getting-started-guide/string-translation/

Please, let me know if it helps, have a nice day.

September 19, 2019 at 8:07 am #4602365

magnusT-4

Thanks for great help!

I cant get the plus sign to add language on the "home-page" in the wp-bakery page builder.

As the attached picture show. how can I solve that?

September 19, 2019 at 7:13 pm #4608029

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the upcates. I took a look in your home page from your WordPress Dashboard and noticed you already began a translation process, this is why you don't see the 'plus' icon, instead it have a 'cogs' icon, indicating a translation in progress, you can go ahead and finishing this translation, also you can try a manual translation using the default WordPress page/post editor, for that you can turn off the option 'Use WPML's Translation Editor' (see attached screenshot).

You can learn more regarding the translation process at: https://wpml.org/documentation/translating-your-contents/ and https://wpml.org/documentation/getting-started-guide/#how-to-translate-pages-posts-and-custom-posts.

Please, let me know if it helps, have a nice day.