If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Dennis 10 months ago.

Assigned support staff: Dennis.

Author Posts
January 21, 2019 at 8:28 pm #3113973

pawelB-14

I am trying to enable "elementor" compability? when i press enable there is red box - smth goes wrong...

then.. it backs to "enable" prompt.. but doesnt work either...

January 22, 2019 at 6:06 am #3114945

Dennis

Hi,

Welcome to WPML Support forum.

#1

Please increase the PHP Memory Limit (your current setting is 40M). Minimum requirements are 128Mb:

https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Add it above the line

 /* That's all, stop editing! Happy blogging. */ 

#2

Could you tell me a little more about the issue? Does it work when you deactivate all WPML plugins?

If yes, could you please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

Edit wp-config.php and insert the following lines:

/*enable debugging*/
define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false);

- Add it above the line

 /* That's all, stop editing! Happy blogging. */ 

Browse to the page with the issue and/or reproduce the issue.

Locate the debug log in: /wp-content/debug.log. You can share with me the debug.log content using pastebin.com and just share me the link.

Having a little more information about the situation will help me evaluate and get the issue sorted faster.

Thanks,
Dennis

January 22, 2019 at 6:43 am #3114958
pawelB-14

Ok, i tried something else which was successful - i disable additional elementor addons then active WPML and then enable additional elementor addons... looks ok but not sure if i want to translate this elementor addons...?

IS WPML compatibile with elementor premiumpaid addons? Like Powerpack, namago, elementor extras?

I have also second question...

I want to use /en /de options but on start i saw an error about "possible will not work"... so i try "parametr" option... and it works ok... after that i try /en option and this "red error" dissapear... (but i didnt change anything ...) 🙂 Any idea what happend?

January 22, 2019 at 9:03 am #3115258

Dennis

Hi,

Thank you for your reply.

#1

It seems to be a compatibility problem with your Elementor addons.

According to our list, PowerPack for Elementor is compatible with WPML. Unfortunately, I was not able to find Namago and Elementor Extras in our plugin compatibility database. I would recommend to use plugins that are compatible with WPML to get rid of compatibility issues.

https://wpml.org/documentation/plugins-compatibility/

#2

In order to help us to bring you a great service and also help other users to find all the information here exposed, it's better to keep only one issue on each ticket. For that reason I have created a new thread regarding the new question you have. I'll check it out in a few moments.

Thank you for understanding.

Kind regards,
Dennis