Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by Carlos Rojas 4 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 28, 2019 at 3:38 pm #4295619

hugoC-2

I am trying to: set up language directories

Link to a page where the issue can be seen: radiorg.anmdev.be

I edited the htaccess file according to your instructions on https://wpml.org/forums/topic/cannot-activate-language-directories-16/

hidden link reported

<!--<em><u>hidden link</u></em>;

But still no result.

This is my htaccesss file:

# HTTPS forced by SG-Optimizer
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ <em><u>hidden link</u></em>{SERVER_NAME}%{REQUEST_URI} [R=301,L]
</IfModule>
# END HTTPS
AddHandler application/x-httpd-php71 .php .php5 .php4 .php3

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress
AuthType Basic
AuthName "xxx"
AuthUserFile "/home/username/.htpasswds/public_html/xxx/passwd"
require valid-user
July 29, 2019 at 7:05 am #4297259

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

July 29, 2019 at 3:26 pm #4301433

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi Hugo,
Thank you very much for the information provided.

However when I try to visit the login page I get a pop-up asking for credentials. Could you edit your previous (private) message and add the credentials for the pop-up?

Regards,
Carlos

August 1, 2019 at 9:33 am #4320225

hugoC-2

Hi Carlos,
I added the pop-up credentials as you requested; did you already have the chance to take a look at my issue?
Regards
Hugo

August 1, 2019 at 11:36 am #4321187

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi Hugo,
Thank you for your message. This time I was able to log in to the site.

When I visit hidden link
I don't get the expected result '<!--hidden link;'

I recommend you to contact your hosting provider and explain them this issue, they should be able to help you with this configuration.

Please keep me updated.
Regards,
Carlos

August 7, 2019 at 4:20 pm #4356747

hugoC-2

My issue is resolved now. Thank you!

August 8, 2019 at 9:13 am #4361429

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.

Regards,
Carlos