This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by zsoltE-2 1 year ago.

Assigned support staff: Riffaz.

Author Posts
October 12, 2018 at 4:41 am #2810750

zsoltE-2

Tell us what you are trying to do?
Activate WPML Multilingual CMS 4.0.7
I clicked the activate plugin button. The result: Parse error: syntax error, unexpected end of file in /wp-content/plugins/sitepress-multilingual-cms/vendor/twig/twig/lib/Twig/Environment.php on line 1517

What is the link to your site?
I make a clone of my site. You can access to it:

October 12, 2018 at 5:58 am #2810855

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

The forum is public.
So please avoid providing login credentials in public.

I've removed your credentials and set the next reply as private (So only you and I can see the details.)
Please provide your login details for both WordPress site and FTP in the next reply if you still need help after you try below explained solutions.

Before that,

#1
could you please delete the current WPML plugin and install it again? then try to activate.
It seems like an incompatibility issue, server limitation or incomplete installation.

#2
Create a new site / fresh installation of WordPress.
Install WPML plugin only and check.

Let me know.

Regards,
Riffaz.

October 12, 2018 at 8:23 am #2811164

zsoltE-2

Hi Riffaz,
Your answer was a nice hit. I deleted plugin files and copied them via FTP. Now it runs. Probably any of the plugin files was corrupted.

Thank you very much.

October 12, 2018 at 8:26 am #2811170

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

You are welcome.

Thank you for confirming.

Regards,

October 12, 2018 at 8:28 am #2811175

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

And, a rating is appreciated. 🙂

October 12, 2018 at 8:32 am #2811221

zsoltE-2

My issue is resolved now. Thank you!