This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Client is trying to a new language but after updating, the page refreshes and language is gone again.

Solution:

Client confirmed that the issue was with the redis cache. After flushing it, the problem was gone.

This topic contains 5 replies, has 2 voices.

Last updated by Dennis 5 months, 2 weeks ago.

Assigned support staff: Dennis.

Author Posts
April 25, 2019 at 3:31 pm #3683955

daanB

I am trying to add a new language (DE) but after updating, the page refreshes and language is gone again.

April 26, 2019 at 5:59 am #3687947

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

#1

Please increase the WP Memory Limit (your current setting is 40M). Minimum requirements are 128Mb:

https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Add it above the line

 /* That's all, stop editing! Happy blogging. */ 

#2

Could you please try these steps and see if it resolves the issue?

Note: Please make sure to make a complete backup of your site before proceeding.

-Go to WPML>>Support page
-Click on Troubleshooting link (link in the middle of the page)
-In Troubleshooting page, please click on the following options of 'Clean up' section. Wait for confirmation of processing after each one.
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment

Please let me know how it goes.

Kind regards,
Dennis

April 29, 2019 at 8:11 am #3700907

daanB

Hi Dennis,

Unfortunately your tips did not resolve the matter. However I found out that our Redis Cache Configuration is resetting the active languages. I aksed our provider to look into this but if you have any insights, your input is much appreciated.

Cheers!

April 29, 2019 at 12:23 pm #3703121

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your update.

It might be the reason why the issue occurs. If possible you can try deactivating your redis cache and check if it resolves the issue. If it is, then the issue could be related to redis cache.

Kind regards,
Dennis

May 6, 2019 at 8:33 am #3745911

daanB

Hi Dennis,

It was the Redis Cache. After flushing it, the problem was gone. Thanks for your support.

May 6, 2019 at 9:15 am #3746231

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Good to hear that your issue is now resolved and also for informing us how the issue was resolved. Please feel free to open a new ticket if you experience any WPML related issues in the future.

Have a nice day!

Kind regards,
Dennis