This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Bruno 3 weeks, 4 days ago.

Assigned support staff: Bruno.

Author Posts
September 17, 2019 at 11:39 am #4588059

nickI-4

I am trying to: Auto register some strings i use in my custom template

Link to a page where the issue can be seen: hidden link

The "Read more" at the right of the gray box it is declared in the code like
<?php _e('Read more', 'sustainforlife'); ?>
The string is not declaring in the backend in String Translation section.

September 17, 2019 at 11:01 pm #4591233

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. On the WPML > String Translation, the "Auto register strings for translation" is enabled (see at the bottom of the page)?

Also, is your server using any cache system? If so, could you disable caching for testing?

Thank you.

September 18, 2019 at 2:40 pm #4597657

nickI-4

Yes the Auto register is enabled
"Strings from all text domains will be auto-registered"
Also i'm in development server and i have no cache.

September 21, 2019 at 2:52 am #4614951

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for the explanation. Are you using this on any child theme or are you using on theme parent?

Also, please as a test, could you disable all non-WPML plugins, switch to the default theme and see if the problem persists? Just add the string in the default theme to test.

If the problem is fixed, please, enable the plugins one by one to see if there is any compatibility problem between these plugins.

Thank you.

The topic ‘[Closed] Cannot auto register custom template strings’ is closed to new replies.