This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: In Woocommerce > Woocommerce Multilingual > Attributes I cannot changes languages of the attributes. The page keeps saying 'Loading..'. Waited for hours, it's doing nothing. How to fix soon?

Solution: The cause of the issue was that the attributes were set to 'Not Translate' in WPML -> Settings -> Taxonomy Translation section. I set the attributes to 'Translate' and now the issue is solved.

Relevant Documentation:

This topic contains 7 replies, has 2 voices.

Last updated by Carlos Rojas 2 months, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
August 7, 2019 at 6:58 pm #4357623

maxL-15

In Woocommerce > Woocommerce Multilingual > Attributes I cannot changes languages of the attributes. The page keeps saying 'Loading..'. Waited for hours, it's doing nothing. How to fix soon?

hidden link

August 8, 2019 at 12:10 am #4358669

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

August 10, 2019 at 4:35 pm #4375821

maxL-15

Did all of the above. Still haveing the same issue. Please check it out for me.

August 12, 2019 at 6:58 am #4378647

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

August 12, 2019 at 1:12 pm #4381119

maxL-15

ready!

August 12, 2019 at 2:28 pm #4381637

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your message.

The cause of the issue was that the attributes were set to 'Not Translate' in WPML -> Settings -> Taxonomy Translation section. I set the attributes to 'Translate' and now the issue is solved.

Please go to Woocommerce -> Woocommerce Multilingual -> Store URLs tab and translate the untranslated slugs. Also visit the Status tab and fix all the issue that appear there so the Store will function correctly.

Could you confirm that the issue is solved?
Regards,
Carlos

August 14, 2019 at 8:28 am #4393371

maxL-15

My issue is resolved now. Thank you!

August 14, 2019 at 10:22 am #4394111

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos