This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by sandys-2 1 year ago.

Assigned support staff: Bruno.

Author Posts
October 9, 2018 at 6:42 am #2798382

sandys-2

I am trying to change value for "Post Type Translation" and "Taxonomies TRanslation".
After I set my preferences and clicked "save", a message showed "Data Saved".
But after the page refresh again, the setting is back to its default value again.

Also in the "taxonomy translation" I get big notice informing that I need to enable WPML translation editor.(see attached). Where do I do that?

The debug.log not showing any errors. I tried changing the max_input_vars to 10000. But still no luck. When I tried the "reset and deactivate WPML" it gave the following :
We have detected a problem with some tables in the database. Please contact WPML support to get this fixed.

Table 'sandyind_wp721.wp1j_icl_strings' doesn't exist

Array
(
[language] => en
[context] => WPML
[gettext_context] =>
[domain_name_context_md5] => c9203e3110feb389a62b2f341a6c346a
[name] => Text for alternative languages for posts
[value] => This post is also available in: %s
[status] => 0
[translation_priority] => optional
[allow_empty_value] =>
)

What should I do?

Thanks
Sandy

October 10, 2018 at 12:00 am #2802369

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

This looks like a database table was not created correctly. This problem is happening after you reset WPML and disabled WPML String Translation?

Also, I've noticed that you are using 128MB of memory. The WPML requires at least 128MB, but you have many plugins enabled.

Please, could you increase the memory limit for WordPress? To do it, please open the wp-config.php file in the root of your WordPress installation and after the opening PHP tag, add these lines:

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

E.g.:

<?php

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Then save the file and using your FTP client, upload wp-config.php to your server. After following these steps, please let me know if you can install WPML properly.

Thank you.

October 10, 2018 at 12:27 am #2802408

sandys-2

Hi Bruno

This problem "Table 'sandyind_wp721.wp1j_icl_strings' doesn't exist" happened after WPML reset. I just restored my site to previous state and increase the memory limit to 256.

1. No more error "Table 'sandyind_wp721.wp1j_icl_strings' doesn't exist"

2. Still have big notice informing to enable WPML translation editor. When I clicked enable, I get the following message:
One more step before you can translate Visual Composer
You need to enable WPML's Translation Editor, to translate conveniently.
This action is not allowed

3. Still cannot change value for "Post Type Translation" and "Taxonomies TRanslation".
After I set my preferences and clicked "save", a message showed "Data Saved".
But after the page refresh again, the setting is back to its default value again.

Thanks
Sandy

October 10, 2018 at 7:18 am #2803162

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi Sandy,

Thank you for testing the steps above.

I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please let me know exactly what steps should I follow to see the problem.

*** Please, can I install the Duplicator or All in One Migration plugin to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

October 11, 2018 at 1:33 am #2806113

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you. This looks like it's related to your site's cache. After following the steps below, the option was saved correctly:

- Click on the WPML > Settings > How to translate posts and pages
- Select the "Use the Classic Translation Editor" option
- Click on the Save button
- On the top bar, click on the "Purge SG Cache" button

It seems that the SG plugin is doing the same aggressive caching of internal pages. For issue 3, however, this still seems like it is not saved correctly, but no error is happening. That is, this also seems to be happening through the cache.

In my test environment (which does not have this cache) this problem does not happen.

Please, could you contact your web host and ask about how you can edit the cache so the site does not cache the backend?

Thank you.

October 11, 2018 at 3:27 am #2806621

sandys-2

Hi Bruno

Issue no.2 I think it's solved.

I disabled and deleted the SG Cache plugin. But still cannot save the changed value for "Post Type Translation" and "Taxonomies Translation". Everything will just revert back to default

Do I need to unsintall and re-install WPML?

Thanks

October 11, 2018 at 8:12 am #2807114

sandys-2

Hi Bruno

Just to give a quick update. I did a new clean install of wordpress and before installing WPML I made sure SG Cache plugin was disabled. This time I managed to finish installation without any problems at all.
I can change settings for taxonomy and post type translations and the values would stick and not revert back to default.
It was probably because of a bad install and some files were corrupted or conflict with SG cache plugins
But its resolved now

Thanks
Sandy

October 11, 2018 at 8:13 am #2807120

sandys-2

My issue is resolved now. Thank you!