Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by ka-chuS 1 year, 10 months ago.

Assigned support staff: Bigul.

Author Posts
September 17, 2018 at 4:49 am

ka-chuS

Theme: The7 Theme (Child Theme) from the Dream Theme

My Problem:
Problem 1:
Cannot find the string to translate "Default Button" <--- Solved!

I added the following code to "Custom XML Configuration" and I am successful to see the button section in the translation page now.

<wpml-config>
<shortcodes>
<shortcode>
<tag>dt_default_button</tag>
<attributes>
<attribute>link</attribute>
</attributes>
</shortcode>
</shortcodes>
</wpml-config>

However!!

Problem 2:
Before solving the above problem, I have translated my homepage already. Now, I can translate the "Default Button" used on other pages because they are not translated before. However, I just cannot translate the button on my homepage because such button section does not exist in the homepage translation page.

My Expectation:
I want to delete the homepage and start all over again, hope this way I can see the button section in the translation page.

Or other better alternative you could provide.

My site is still working in progress in my localhost. If you need to access, please tell me how I can give you the copy.

Thank you for your help!
P.S. I dont know what is *_archive.zip

September 18, 2018 at 7:09 am #2743741

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

It may be happening because of the translation sync issue between the Homepage and its translations. Please make a sure the translation of Homepage is completed or not. Then make a minor change to the Homepage(to refresh the translation settings) and visit the translation in WPML Translation Editor and check you can translate the *Default Button* or not.

If you are still having the issue, please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

September 18, 2018 at 7:27 am #2743781

ka-chuS

Thanks for your help Bigul! But I already reset all over the WPML plugin and it's ok now. If the problem occurs next time, I will definitely try your method!