This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Translations are mixed up on some pages. I cannot update any page that is translated to any language (only english - default language is working).

Solution: This was a bug and fixed in latest version of WPML.

Relevant Documentation: - https://wpml.org/errata/when-the-translation-is-saved-some-content-is-replaced-with-the-original/.

- https://wpml.org/errata/cannot-edit-page-builder-translations-with-the-native-wordpress-editor/

This topic contains 7 replies, has 2 voices.

Last updated by Lorry Gombos 8 months, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
December 2, 2018 at 6:04 pm #2960373

Lorry Gombos

Tell us what you are trying to do?

Before a week ago everything works fine. But from then, all translations are messed up! Not only that, I even cannot update any page that is translated to any language (only english - default is working) which is pure WPML issue.

Try to check for example homepage on any language rather than english and try to do any change in Visual composer. It will just ignore that change.

What is the link to your site?
hidden link

December 4, 2018 at 7:06 am #2965117

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

- I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Could you please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except (WPML, WPBakery Page Builder) and see if this issue goes away with default theme and only WPML activated?

If still issue persists, please enable error reporting at you site as I need to see the detail of the error log. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/
https://codex.wordpress.org/Debugging_in_WordPress

To enable it, open your ‘wp-config.php’ file and look for ‘define(‘WP_DEBUG’, false);’. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

define( 'SCRIPT_DEBUG', true );

This will create debug.log file in your site's wp-content directory. Please send me its contents.

Thank you

December 4, 2018 at 4:03 pm #2967304

Lorry Gombos

Sure I did it. But can you provide me field so I can upload private informations and put them all in there? I've also tested, but when I changed theme and disable all plugins, seems like this issue is still present.

December 4, 2018 at 5:05 pm #2967461

Lorry Gombos

Ok, please close this ticket and transfer things on another ticket: https://wpml.org/forums/topic/cannot-update-any-page-rather-than-english-default-one/ where I provide all details. Please this is urgent issue and you are send me one reply per day. Please be professional. Thank you.

December 5, 2018 at 9:01 am #2969254

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hello, okay we are checking on your new ticket. Sorry for delay, we are getting high load of tickets in our queue at moment due to which there is a delay. We are trying to help you asap. Thanks

December 5, 2018 at 3:52 pm #2970695

Lorry Gombos

I understand, but this issue is really big deal! I really hope that you can check what's wrong asap. Please check other ticket details, I provide all data details so you can access things and check what is wrong.

December 5, 2018 at 4:50 pm #2970926

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Yes Marcos is already working on your ticket and he should be able to help you. As a quick hint, you can check and confirm if any of the known issues and solutions are related or not:

- https://wpml.org/errata/cannot-edit-page-builder-translations-with-the-native-wordpress-editor/

- https://wpml.org/errata/when-the-translation-is-saved-some-content-is-replaced-with-the-original/

Thanks

December 10, 2018 at 9:54 pm #2986136

Lorry Gombos

My issue is resolved now. Thank you!