Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Raja Mohammed 4 months, 3 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
June 22, 2019 at 10:00 am

ernestasK

I am trying to: duplicate all custom fields to other languages

Is there any other way to create all fields at once instead of creating every field for every language? Strings do not appear in string translations tab. The only way i found possible is creating independently translatable field for every language, what is very slow and massive work.

June 24, 2019 at 7:30 am #4075033

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Welcome to our forum, I will help you with your ticket.

ACF custom fields will be available for all languages when used with ACF Multilingual plugins, Can you please confirm whether the custom fields are coming from ACF plugin or do you use any other plugin to create custom fields.

Also, please let me know the steps how can I reproduce the issue.

Kind regards
Raja

June 26, 2019 at 7:21 am #4089995

ernestasK

I'm using Custom Fields plugin. You can enter it as shown on a screenshot. The issue that the only way to translate these fields is by creating independent translations. Is there are other possible, normal way to do this?

June 26, 2019 at 2:09 pm #4093111

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Try setting the wccf_product_field post to "Not Translatable" in WPML > Settings> Post type translation this will display custom fields in all product languages.

Please let me know if that helps.

Kind regards
Raja

June 26, 2019 at 2:28 pm #4093275

ernestasK

Okey, now all of them are just in Lithuanian. And what now? How am I supposed to translate them, if they do not appear in String Translations?

June 27, 2019 at 2:55 am #4096063

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Please apologize, I think I mixed up a bit.

Since custom fields are registered as a custom post type the translation should be created for each custom fields manually. However, you don't need to repeat the process of creating the fields in the translation when you use the duplicate content option in WPML.

Please change the translation preference for "wccf_product_field" post type to "Translatable – only show translated items." and follow the below steps to fasten the translation process.

1) Goto Custom fields ->Product fields, Edit a custom field on the right languages section select Duplicate option to copy all the field content to the translation,

Alternatively, you can duplicate multiple posts and pages from the WPML -> Translation Management Dashboard page.
https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/#batch-duplicating

2) Open the transition in the editor. In the section Language, click the button "Translate independently".

This is the best way to speed up the process of your translation.

Please let me know if this helps, In case if you need further assistance, Feel free to write back i will be happy to help.

Kind regards
Raja