Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Puntorosso 1 year ago.

Assigned support staff: Yvette.

Author Posts
October 21, 2018 at 5:16 pm

Puntorosso

Hi,

I am trying to duplicate a page "/hochzeiten/" from german to swiss in a site wit domain/language but it doesn't work.

Tried all standard procedures but not results.
Even deleting all pages in that particular language doesn't work.

May you have a look?

Thanks

Best

October 22, 2018 at 10:15 pm #2839998

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

I´ll be helping you. I logged into your system but was unable to get to the WordPress dashboard.

Can you please check that the privileges associated with the userid are sufficient to see the wp-admin panel?

Thanks

October 22, 2018 at 10:30 pm #2840002

Puntorosso

sorry, my mistake.
try now.

thanks

October 23, 2018 at 7:37 am #2841185

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

I see what you are trying to do but this is not possible as there can only be one "original" language for a group of linked translations.

For this page, the "original" /"source" language is the EN version. If you want to "duplicate" a post, it must be from the original language to the target language.

In your case, I have created a translation of the German post and this is permitted. You can copy all the content form the German post to the Swiss post but it cannot be "duplicated" as German is not the "original" language post.

Does this make sense?

October 26, 2018 at 8:23 pm #2854188

Puntorosso

Hi,
thanks for your help.

It's strange, because it always worked before, and it still works with new pages/posts.
Only this particular page doesn't allow that.

Best

October 29, 2018 at 8:45 am #2857139

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

You wrote: "... it still works with new pages/posts."

I´ve just confirmed this on my test site. So, I spoke too hastily! Do you want me to investigate this further? I am curious now to know why it was not working.

Please let me know and my appologies for having given you the wrong answer.

October 29, 2018 at 8:48 am #2857143

Puntorosso

No need to worry 😉 I will be more than happy if you can investigate the problem and give me a solution!

Thanks
Best

October 29, 2018 at 10:07 am #2857429

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Can I work on the page that you provided? I see that it has already been translated. Here is what I will do:

1. Temporarily detach the Swiss version that you created (it will not be deleted but will exist as an independent page for now)
2. Then I will study the problem
3. Afterwards, I will re-attach the Swiss version that you currently have created.

Are you ok with these steps? Could you also please install and activate the ARI Adminer plugin?
Thanks

October 29, 2018 at 11:03 am #2857574

Puntorosso

Ok.
Ari adminer installed.

Thanks

October 29, 2018 at 3:01 pm #2858495

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

I have temporarily unlinked the Swiss version of the page and then edited the German page:
/hochzeiten/

This time, the option to "Duplicate" was available. So I marked it and made a Duplicate.
Can you check it?

I think there must have been a glitch in the translation status that maybe thought there was somehting still pending to complete. But it does not seem to be replicable now.

I wait for your thoughts.

November 10, 2018 at 4:57 pm #2895749

Puntorosso

Hi,
Now the German translation is disconnected from the english original page.
If I try to reconnect, it looks great at first, but when I save the page it will disconnect once again.

hidden link

May you have a look?

Thx

Best

November 11, 2018 at 3:37 pm #2896621

Puntorosso

I was able to connect to the english page, but now it looks weird in the Pages list.
While the english version display correcly this page as Parent and the sub-pages afterward, in the german version they are separated and you get a never saw before "Parent Page ....." label.

hidden link

November 12, 2018 at 6:54 am #2897590

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello again.

I am able to replicate the following issue on my local test site:

- Install 3 languages : EN , ES, FR
- Create a sample page in EN
- Create a translation of the page in ES
- Create a duplicate of the ES page in FR
- Update the ES page
- Result: all translation links are set to blank

So this looks like it is a bug or it is, as I originally thought - unsupported scenario. I need to report it and get a definitive answer. For the time, I can only suggest that you relink the pages whenever you update the DE version.

Alternatively, you can set the DE version of the page to be the "source"/ "original". When I do this on my test site, the translation links int he group remain intact when I edit, afterwards, any of the other pages.

With regards to the pages hierarchy, I just "updated" the DE pages and the hierarchy was restored.
Do you see it?

For the other issue, are you able to move forward with the workaround options I provided?
Thanks

November 14, 2018 at 2:45 pm #2906848

Puntorosso

Ok, thanks.
I will use the workaround for now.
Let's hope in a future update.

Best