This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 18 replies, has 2 voices.

Last updated by Raja Mohammed 3 months, 1 week ago.

Assigned support staff: Raja Mohammed.

Author Posts
June 14, 2019 at 10:44 am #4020627

andyT-11

I am trying to: Duplicate the English Language pages to other pages in either Classic Editor Mode or Advanced Editor Mode, but it doesn't fully work.

Link to a page where the issue can be seen:

I expected to see: overwrite the content and format of the English Pages, in exactly same content and same format, same style.

Instead, I got:

I can copy the text after clicking the duplicate English Pages, but in plain text only, it cannot duplicate the Elementor format.

attached screenshot:

wpml-2.png: orginal page

wpml-1.png: the duplicate page

I have two following questions:

1. Will the Classic Editor be taken place by the Advanced Editor in the future planning of WPML? I am not sure if I should choose the Classic one or Advanced one. I use the Classic Editor in other websites before, but this website is a new one. I can free to choose the editor at the beginning.

2. In the Classic Editor, there is a choice of "Overwrite the page". But I do only find the Duplicate choice in the Advanced Editor. Is it same as the Overwrite? I want to make the other English page overwrite the content of the English Page. Whenever the English page is updated, the other English pages will be updated automatically, such as en-AU, en-UK, en-US etc. What should I set to make it function properly?

Thank you again for your assistance.

June 14, 2019 at 7:40 pm #4023893

andyT-11

Hi, thank you very much for your messages. I feel terribly sorry of missing your chat message as I did not know there could be an instant chatting service. I thought it was only forum assistance. Thank you for providing such good supporting service.

Regarding your questions:

1. I have try to use all the default widgets provided by the Elementor. I have rechecked that the tab is the default tab.

2. This problem happens same for other pages built by Elementor. The Elementor should be compatible with WPML well. I feel confused about this problem.

3. As for the Classic translation editor & Advanced translation Editor, the advanced one is more powerful. But the "Overwrite Content from the English" is very important, does the Advanced Editor provide this setting?

Thank you again. Looking forward to your support. Let me know if you need any further information. Thanks.

June 17, 2019 at 5:16 am #4032069

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Clients can receive chat support now in a case if there are no supporters or the client got disconnected the chat will be converted to forum ticket for better follow up.

Regarding your issue,

1) Please increase the PHP Memory Limit (your current setting is 40M). Minimum requirements are 128Mb:

https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

2) It would be good if you can provide me with the WordPress debug.log (not WPML debug information).

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:


define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

In this case, the errors will be saved to a debug.log log file inside the /wp-content/ directory.

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in the discussion).

Kind regards
Raja

June 19, 2019 at 3:19 pm #4052727

andyT-11

Hi Raja,

Sorry for my late response. Please see my replies below:

Question 1:

I have been using a managed WordPress and the server managed company has refused my request to increase the PHP Memory Limit from 40MB to 128MB. Their replies are it is not necessary and not relevant technically. And they suggest WPML to cancel this requirement.

Question 2 & 3:

Please find the message of the debug.log below:

https://pastebin.com/PfqHzBkF

If you need any further information, please feel free to let me know.

Thank you again for your help!

June 20, 2019 at 7:48 am #4057341

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thanks for the information,

Can you please let me now the hosting provider details where your site it hosted?

I am not sure how a request to increase memory limit can be technically irrelevant, Maybe you can share with your hosting provider the minimum requirements mentioned in our official documentation
https://wpml.org/home/minimum-requirements/

If the increasing memory limit is still not possible then WPML may not function properly.

There are not many details in the debug log related to the issue.

I can try to isolate the issue in one of our private servers, to confirm whether the issue is related to the memory limit. Please let me know if that is okay I can send you the migration instructions.

Kind regards
Raja

June 20, 2019 at 2:05 pm #4060551

andyT-11

Hi Raja, I can send you the name of the hosting provider in a private message. Please send me the migration instructions.

June 20, 2019 at 2:40 pm #4060717

andyT-11

Hi Raja, they replied that the default PHP limit is 256MB. It is no need to increase it from 40MB to 128MB. They said it in a quite confident way. I guess that the problems of my website are not caused by the PHP Memory Limit.

June 21, 2019 at 4:43 pm #4068527

andyT-11

Hi Raja, Thanks

June 21, 2019 at 5:53 pm #4068863

andyT-11

Hi Raja,

It is migrated successfully already.

Looking forward to your support. Thanks.

June 24, 2019 at 7:05 am #4074913

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Inspecting the error logs it seems like Yoast is conflicting with WPML and it is trying to register a post meta without post id which breaks the duplication process.

1) Disable Yoast or activate the premium account
2) It seems your WPML subscription has ended or not valid, Please register the WPML and update the plugins to the latest version

Check if the issue persists, Let me know the results.

Kind regards
Raja

June 25, 2019 at 4:01 am #4081247

andyT-11

Hi Raja,

Yours is a duplicated site; thus, the yoast premium subscription & the WPML Subscription don't work. The production site has both activated & licensed subscription.

But the Yoast Premium account has been activated since I opened this ticket.

Is it the only way to deactivate the yoast (does it mean we give it up?) to solve this problem?

I try to deactivate the yoast plugin, and duplicate the pages, I need your further instructions by the following settings:

hidden link hidden link (yoast deactivates)

when I view the hidden link, it will be forwarded to the page to hidden link. It is same for other duplicated pages. All the duplicated pages have been forwarded to the hidden link.

Thank you again.

June 25, 2019 at 2:38 pm #4085545

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

If deactivating Yoast solves the problem then it's most likely a compatibility issue.

To obtain detailed debug information Let me check this further in my local environment. I will keep you posted with any updates

Kind regards
Raja

June 25, 2019 at 3:44 pm #4086083

andyT-11

Hi Raja, I have not conclusion yet. I don't know if it could solve the problem or not after deactivating the yoast. Because I cannot view the duplicated pages.

hidden link hidden link (yoast deactivates)

when I view the hidden link, it will be forwarded to the page to hidden link. It is same for other duplicated pages. All the duplicated pages have been forwarded to the hidden link.

I cannot view the duplicated pages. No ideas if it could solve the problems or not.

June 25, 2019 at 7:56 pm #4087043

andyT-11

Hi, I have solved the problem of duplicated pages redirecting to home page.

However, after deactivating Yoast, it cannot solve the titled problem. The page format cannot be duplicated.

Looking forward to your solutions.

June 26, 2019 at 3:00 pm #4093479

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Sorry for the delay here, I have a few interruptions while creating the local copy of your site. I will update you once have the local copy ready. Right now I am copying the wp-contents folder to the local environment since creating duplicator package doesn't seem to be a feasible soliton with the private server

Kind regards
Raja

The topic ‘[Closed] Cannot duplicate the Elementor Page "en" to other language “en-UK”’ is closed to new replies.