This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Riffaz 1 year, 3 months ago.

Assigned support staff: Riffaz.

Author Posts
February 18, 2019 at 9:40 am


I am trying to: Site Languages/Edit Languages/Custom Flag/Choose File then SAVE

Link to a page where the issue can be seen: hidden link

I expected to see: Saved Language with new Flag like my other sites

Instead, I got: A blank page with only the standard WP messages on top and nothing else. When I go back to edit, no changes are applied.

February 18, 2019 at 10:41 am #3211294


Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Plugin conflict
Could you please disable all the plugins and check this?

Minimal Setup
If you disable all non-related WPML plugins, switch to one of the default themes like twenty seventeen, the problem persists or not?
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Console Errors
In your chrome browser Press Ctrl + Shift + J (Windows / Linux) or Cmd + Opt + J (Mac) before you go to this step.
Check if you see any red errors here : hidden link and let me know.

If you do not find anything as I explained above please enable the WP Debug mode as explained here and let me know the error message you see when you try to save again:

normally, when you upload flag on WPML->Languages->Edit languages, they will always be resized to 18x12px. If you want to have bigger flag images, you'll need to upload them manually via FTP:
1. Log into your FTP.
2. Go to the wp-content/uploads/flags folder.
3. Upload the flag image there.
4. On WPML->Languages->Edit languages, in the flag column, provide the file name of the previously uploaded flag.

Let me know how it goes.


February 19, 2019 at 12:26 pm #3216524


I was hoping to get a quick reply with some hint or some way to resolve this quickly like every other software support. Every small issue with WPML has to go through that lengthy debug procedure you always request from everyone. This will take time from me which today I don't have. I will do it later. Thanks anyway.

February 20, 2019 at 9:52 am #3220611


Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)


We are giving full details and complete steps to troubleshoot.
So there won't be any mistakes.

Ok, take your time and reply to this ticket when you are ready.


The topic ‘[Closed] Cannot Edit and Save Languages’ is closed to new replies.