This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Andreas W. 1 month, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
August 28, 2019 at 5:43 pm #4476167

timM-15

All Beaver Builder Page blocks have disappeared from the Translation Editor for me. Attached are screenshots showing our staging site vs our production site with the exact same plugins and content. I do not know how this happened or how to get the Beaver Builder blocks to show up again.

August 28, 2019 at 10:21 pm #4476985

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Could you please verify if the Beaver Builder post types and taxonomies are set to "translatable" at WPML -> Settings?

If not, apply the settings then try to translate again. Also please verify if the issue is getting solved after making small edits (for example adding blank spaces to each element´s title or text) on the original page, saving the page and then translating it again.

Relative documentation:
https://wpml.org/documentation/plugins-compatibility/beaver-builder/

Let me know about the outcome.

Kind regards
Andreas

August 29, 2019 at 2:43 pm #4481833

timM-15

How do I verify this in the settings? Attached is what is set currently. I tried changing the beaver builder taxonomy on but it didn't make a change.

I tried making a small edit to a page and that did not help either.

August 29, 2019 at 4:37 pm #4482757

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

August 29, 2019 at 10:28 pm #4483709

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

All the fields do show up after setting the custom field for the Beaver Builder data to translate.

This setting can be found at the bottom of the page editor inside of the Multilingual Content Setup section. This is a global setting and will be applied to all pages.

The only unexpected hing her eis that the field does not only include text and links but also the css for the whole page, which ususally should be copied.

It seems that this might be related to change sin Beaver Builder. As I can see that the current version is outdated please update all you plugins and let me know if the issue persists.

Kind regards
Andreas

September 4, 2019 at 6:46 pm #4513643

timM-15

Thank you for you help with this. How do I enable this custom field for translation on all pages? I do not see these fields on the systemwide settings page?

September 4, 2019 at 6:56 pm #4513735

timM-15

Also, this is what I now see when I enable the two custom fields highlighted in your response.

September 5, 2019 at 5:45 pm #4521171

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

In fact, I can see that there are issues with the translations and there are many design or layout fields appearing on the WPML Translation Editor. Those fields should ususally be copied, but any translatable content like text and links should appear in the translation editor.

Could you please provide me detailed steps about how to recreate the issue and provide all plugins used to generate an example page, and install those plugins on the following test site:

One Click Login: hidden link

It would be very helpful if you could recreate a simple page with Beaver Builder, include templates if used and also include any content that is based on additional plugins.

Leave me a short notice once the site is ready.

Kind regards
Andreas

The topic ‘[Closed] Cannot edit Beaver Builder Page Text for Any Pages’ is closed to new replies.