This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Shekhar Bhandari 7 months, 3 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
February 11, 2019 at 1:38 am #3180365

rutvikM

Tell us what you are trying to do?
I'm trying to import multiple languages. Has custom post types and ACF. Using XML files

Is there any documentation that you are following?
https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/

Is there a similar example that we can see?

What is the link to your site?
hidden link

I cannot figure out what I'm doing wrong. I've spent 6+ hours working on this and cannot successfully import a second language.

I've screen recorded a couple of attempts for you to see.
hidden link
hidden link

February 11, 2019 at 3:59 pm #3183965

rutvikM

The video embeds dont play. here are the direct links
hidden link
hidden link

February 12, 2019 at 12:00 pm #3188281

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Could you please provide me login details so I can quickly check your settings once? I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues needs some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Look forward to your reply.

Thanks

February 13, 2019 at 4:59 am #3192120

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Please follow the below steps:
- Delete the team members from English as well as German
- Delete those from trash too.
- Now upload the English team XML, and while uploading select "New Items" Instead of "Existing Items"
- While uploading note the UNIQUE_ID, this is very important.
- Now upload the German team XML, again while uploading select "New Items" Instead of "Existing Items"

If you feel confused, please follow the exact steps as shown on the video attached in the documentation: https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/

This should fix the issue.

Thanks

February 15, 2019 at 7:49 pm #3206507

rutvikM

I restarted this entire process
1. delete all the team-members 'delete from wp_posts where post_type='team-members'
2. configured wpml-all-import, wp-all-import-pro, wpai-acf-addon
3. tried running the import which says there was a server problem
4. there was a plugin called flamingo which I removed

2019/02/15 19:45:15 [error] 75362#0: *68181 FastCGI sent in stderr: "PHP message: WordPress database error Duplicate entry 'post_flamingo_inbound-4037' for key 'el_type_id' for query UPDATE wp_icl_translations t
JOIN wp_posts p
ON p.ID = t.element_id
AND t.element_type LIKE 'post%'
AND t.element_type <> CONCAT('post_', p.post_type)
SET t.element_type = CONCAT('post_', p.post_type) made by do_action('admin_init'), WP_Hook->do_action, WP_Hook->apply_filters, PMXI_Plugin->adminInit, PMXI_Admin_Import->process, PMXI_Import_Record->process, wp_insert_post, do_action('save_post'), WP_Hook->do_action, WP_Hook->apply_filters, WPML_Admin_Post_Actions->save_post_actions, WPML_Post_Translation->after_save_post, WPML_Post_Translation->maybe_set_elid, SitePress->set_element_language_details, WPML_Set_Language->set, WPML_Set_Language->check_duplicate, WPML_Fix_Type_Assignments->run, WPML_Fix_Type_Assignments->fix_broken_post_assignments" while reading response header from upstream, client: 68.173.138.122, server: test.visionrt.com, request: "GET /wp-admin/admin.php?page=pmxi-admin-import&action=process&id=12&failures=0&_wpnonce=de29852e6d HTTP/1.1", upstream: "hidden link", host: "test.visionrt.com", referrer: "hidden link"

February 15, 2019 at 7:56 pm #3206513

rutvikM

"- While uploading note the UNIQUE_ID, this is very important."
Why am i noting this? what do you want me to do with this piece of information after I write it down?

February 18, 2019 at 3:34 am #3210155

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The unique id is used when importing the translations, you can see the use of unique id in the video link from the documentation, make sure you use the unique id same for the process as shown there.

The link depends upon this unique id so it's very important.

Let me know if this helps.

Thanks

February 19, 2019 at 3:38 pm #3217761

rutvikM

What about the other issue? At this point I still cannot import anything. Please see my reply about the server log.
thanks

February 20, 2019 at 5:28 am #3219944

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Are you mentioning about the flamingo issue? If so, Could you please go to WPML-> Support ->Troubleshooting and click the below buttons and let me know if that helps:

+ Set Language information
+ Clear Cache in WPML
+ Fix element types collation
+ Assign translation status to duplicated content

Look forward to your reply.

Thanks

February 22, 2019 at 10:46 pm #3234226

rutvikM

nope. your suggestions did not help

February 25, 2019 at 4:03 am #3237980

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The Credentials provided earlier in the ticket isn't working anymore, could you please check it once?

You can edit the previous private reply to send the updated details.

Look forward to your reply.

Thanks

The topic ‘[Closed] cannot figure out how to import’ is closed to new replies.