This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by Carlos Rojas 1 year, 3 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 24, 2018 at 9:07 am #2220829

edv-2

I am trying to translate widgets i use in my footer. Some widgets don't show up in string translation, others only show former versions.
I removed the string (that works :-)), but now i want a recent string to translate again. I was not able to restore this.
Can you please help me?
You can see it on the website hidden link in the footer:
Left column the Hague > Den Haag and url instagram
Right column No translation of the form (removed)

thanks!
ed

May 24, 2018 at 10:13 pm #2226065

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- Could you tell me if the issue persists if you add a new widget?

2.- Please provide the debug information of the site. In this link you will find the steps to follow: https://wpml.org/faq/provide-debug-information-faster-support/

Kind regards,
Carlos

May 25, 2018 at 10:33 am #2228466

edv-2

***

May 25, 2018 at 10:36 am #2228468

edv-2

Sorry, could not find the 'provide the debug information' button.
I changed the text but in string translation only find the old text. Also cleared WPML-cache.

May 25, 2018 at 6:09 pm #2231456

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

1.- I'm sorry, it seems the option to provide the debug information wasn't activated correctly. This time you will find the option active.

2.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Best regards,
Carlos

May 28, 2018 at 12:30 pm #2238501

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

Thank you very much for the information provided.

Before we continue I need to ask you to update all outdated plugins and themes to their latest version. Outdated functionalities can cause conflicts in the code.

Could you tell me if the issue persists after finished the steps above?

Regards,
Carlos

May 28, 2018 at 12:39 pm #2238523

edv-2

sorry Carlos
problem still exists 🙁 after upgrading theme and plugins.

May 28, 2018 at 5:10 pm #2240877

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

1.- I would like to ask you to follor this steps:
- Back up your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Regards,
Carlos

June 15, 2018 at 11:18 am #2415397

edv-2

Hello Carlos
I hope you can understand that it is not possible to change the theme in a live situation. My client would not be happy. 🙂
I deleted the contact widget en mailchimp form widgets and now i cannot translate these items
anymore. Replace these widgets is not the solution.
really hope you can help me!
best regards Ed

June 15, 2018 at 1:34 pm #2415679

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Ed,

Could you create a staging/test site where we can make some tests without affecting the live site?

Regards,
Carlos

June 18, 2018 at 8:36 am #2418368

edv-2

Hello Carlos
i made a copy of the site

hidden link
login: ***
pw: ***

Here you can do everything to find the solution.
Good luck!!

best regards ed

June 18, 2018 at 8:27 pm #2420285

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Ed,

Thank you very much for the information provided. I removed the credentials and URL for privacy purposes.

Before we continue I kindly ask you to update the WPML plugin to the latest version we released today and double check if the issue persists.

Looking forward to your answer.
Best regards,
Carlos

June 19, 2018 at 3:29 pm #2422384

edv-2

I updated the plugins and the widgets aren't translatable still 🙂

June 19, 2018 at 9:43 pm #2423308

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Ed,

I followed this steps and now the issue seem to be solved:
- I applied some troubleshooting actions in WPML -> Support -> Troubleshooting link.
- I translated the only untranslated widget body (the one in the center column) in WPML -> String Translation.
- Regarding the newsletter form, I believe you can translate the strings by using the Gettext functions described in this link: https://codex.wordpress.org/I18n_for_WordPress_Developers

Please let me know if you need further assistance and I will be more than happy to help.
Best regards,
Carlos

June 20, 2018 at 9:52 am #2424084

edv-2

still not working, try to translate the left or right widget in the footer. When you look at '2513 CL The Hague' there is no string to translate.