This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by giulioV-3 1 month, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
August 11, 2019 at 10:50 am

giulioV-3

I am trying to: translate blog articles from italian to english. My website is made with Avada Theme. I've installed a child theme. In most articles WPML doesn't recognize strings from page builder so, i cannot translate it in the editor.

Link to a page where the issue can be seen: The issuee can be seen on the backend.

I expected to see: all the strings from Avada, so I can translate it.

Instead, I got:just title string, Yoast SEO strings, some page builder strings and image strings.

August 12, 2019 at 6:31 am #4378511

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I don't know if you had the chance to take a look at this section here:
https://wpml.org/documentation/support/maintaining-the-fusion-builder-avada-compatibility-with-wpml/

Can you please copy the complete content of the document in the link below inside WPML > Settings > Custom XML Configuration, then make a small edit into an original/default-language post/page and then go to the translation page and see if the strings show up now?
hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

August 12, 2019 at 3:23 pm #4381855

giulioV-3

Hello Mihai,
I've did it but it doesn't solve my issue.
I cannot see string from Fusion Builder.

Here's what I did:
1-copied into WPML > Settings > Custom XML Configuration the code at:hidden link
2-made a small edit into the last blog article

How can we solve this? I'm start thinking it doesn't worth the money buying your plugin.

Thank you,
Giulio

August 12, 2019 at 5:40 pm #4382853

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Giulio.

Thank you for trying the steps.

WPML is compatible with most of the major content builders but sometimes there's different incompatibility issues happening due either to other plugins that are active in the same time, server configurations and a lot of other reasons but I am more than happy to take a look for you and try to find out what is the issue, together with my colleagues in the dev team.

Can you please let me know what is the post that you are running the tests on and which is the field that it doesn't get recognized? This will help me focus on one element in the beginning, instead of looking for multiple at the same time.

Please let me know.

Kind regards,
Mihai

August 13, 2019 at 7:28 am #4385565

giulioV-3

Hello Mihai,

I'm running the test on the last italian article published on 20/05/2019 named: Black Sheep Birreria. I cannot see fusion builder container (it's just one) and fusion builder code block (at the bottom of the container).

Let me know.

Giulio

August 13, 2019 at 6:14 pm #4390207

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Giulio.

From what I was able to see, the translation was not published yet for that post (it was showing the gear-icons instead of the pencil-edit icon).

Now I saved the translation so that I can see what part of the content is missing but it seems that is not working.

Each time that I try to see the English version of that post, I get redirected to the first page.

I also see that inside WPML > Lingue, you have some errors showing up and I can also see the Loco Translate plugin installed - it is not recommended that you use multiple multilingual plugins in the same time.

Can you please create a full backup of the site first and then disable all the plugins for the moment?

Please let me know when that's done so that I can continue the investigation.

I will be waiting for your response.

Kind regards,
Mihai

August 13, 2019 at 8:10 pm #4390557

giulioV-3

Hi Mihai,

referring to your previous email my answer will be marked with *

Hi Giulio.

From what I was able to see, the translation was not published yet for that post (it was showing the gear-icons instead of the pencil-edit icon).
*That's right. As you could see from the original post some text-blocks are missing*

Now I saved the translation so that I can see what part of the content is missing but it seems that is not working.
*Thank you for updating me*

Each time that I try to see the English version of that post, I get redirected to the first page.
*This is maybe why I deactivate english language?*

I also see that inside WPML > Lingue, you have some errors showing up and I can also see the Loco Translate plugin installed - it is not recommended that you use multiple multilingual plugins in the same time.

Can you please create a full backup of the site first and then disable all the plugins for the moment?
*I've created a full backup and disable all the plugins. Since I've done this could you please move up faster as I can serve the user a proper website?*

Please let me know when that's done so that I can continue the investigation.

I will be waiting for your response.

Kind regards,
Mihai

August 14, 2019 at 3:44 pm #4396489

giulioV-3

Hello Mihai,

any news?

Best regards.

August 14, 2019 at 9:21 pm #4397627

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Giulio.

Regarding the hidden language, even if you hide it, an Administrator that's logged in should be able to see the page. I resolved that anyway and I was able to find out the translation page.

Unfortunately, after spending a lot of time on the site testing multiple things, I am still not able to understand what is the content missing from the translation page here (hidden link).

If I look at these 2-page links below, I can see all the content on both languages:

- hidden link
- hidden link

I will definitely need some help from you to understand what is exactly what you are referring to when you say "cannot see fusion builder container (it's just one) and fusion builder code block (at the bottom of the container)".

Can you please attach a screenshot or a screen recording video (shared via a google drive or dropbox link) so that I can better understand what do you mean?

Thank you very much.

I will be waiting for your response.

Kind regards,
Mihai

August 15, 2019 at 8:44 am #4399693

giulioV-3

Hi Mihai,

it seems it works fine right now. I can see al the text fields from the original article.

However, even if the problem is fixed on this article, it is not still resolved.

I've got the same problem here's on the article below.

Taking this article as a reference: hidden link
you can see how the fields that are proposed for translation through WPML are not complete.
This is the original article: hidden link

It's like that some text fields are missing.

Here are the articles where I have the same problem:
-hidden link here's the original: hidden link

-hidden link here's the original: hidden link

-hidden link here's the original: hidden link

-hidden link here's the original:hidden link

-hidden link here's the original: hidden link

-hidden link here's the original: hidden link

I think, posting these references where the problem is.

Why I can't see the post using tastycomo.com/en directory?

I will be waiting for your response.
Best regards,
Giulio

August 16, 2019 at 9:51 am #4405761

giulioV-3

Hello Mihai,

any news?

Best regards,
Giulio

August 16, 2019 at 2:53 pm #4407123

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Giulio.

So here is what I did for the first one that you mentioned in your last reply (hidden link):

1. I went to the original language of the post (hidden link)
2. I edited it with Fusion Builder Live (I just edited a space or a word by adding just a letter that I removed after) and saved the original content again - Explanation: this will make WPML set the translation to the "update required" status so you would need to go to the translation process again and re-publish it. We need to do this for each of the posts due to the fact that the WPML XML config code was added only after the posts were created so in order for WPML to recognize those content fields, we need to practically set the translations to the "update required" status and then retranslate+republish them.
3. Then I went to WPML > Support > Troubleshooting (hidden link) and clicked on the following buttons:

- "Clear the cache in WPML"
- "Remove ghost entries from the translation tables"
- "Fix element_type collation"
- "Set language information"
- "Fix terms count"
- "Fix post type assignment for translations"

4. After that, I simply went to the translation page (that was now currently set to "update required" status) and the fields that were not showing are now showing (hidden link)

This is what would need to be done for the other posts.

I hope that this explanation helps.

Please let me know how that goes.

I will be waiting for your response.

PS: Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai

August 16, 2019 at 6:09 pm #4407815

giulioV-3

Hello Mihai,

quite easy and done! Now it works fine, I can see all the fields that were missing.

Something new happened on this post: hidden link
The field that you can see on the attached simply doesn't work. I've tried marked as translated but nothing happened.

The same happens for article: hidden link
on wpml_string_wrapper: content

and on this article hidden link
at fusion_text: content

and on this too: hidden link
on wpml_string_wrapper: content

on this too: hidden link
on fusion_text: content

on this too: hidden link
on fusion_text: content

Have a great weekend! Talk to you on Monday.

Best regards,
Giulio

August 19, 2019 at 4:38 pm #4417493

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for your patience.

Can you please confirm to me that those 2 fields that you mentioned (the extra "fusion_text: content" field and the "wpml_string_wrapper" have any importance for you in the translation of the page content)?

My guess is that these fields are adding somehow due to an incompatibility between WPML and some plugin or theme that you use but I don't' know how significant of a role does that have in translating the page content.

For example for this first link you shared (hidden link) I simply translated all the fields and then saved it (attaching screenshots).

When you go here now (hidden link) everything is at 100% translated status and the translation is published.

Can you please check and see if these things don't obstruct you from translating the content?

Can you please check what I did and let me know if that resolved the issue?

I will be waiting for your response.

Kind regards,
Mihai

August 22, 2019 at 5:17 pm #4441821

giulioV-3

No, I didn't solve my issue but I don't want help anymore because with every help I receive a new bug is showed.

I try to do it by myself and if I don't fix, I will ask you for refund because it's not possible to spend over than a week without a markable result.

best regards.