This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Marcel 3 months ago.

Assigned support staff: Marcel.

Author Posts
May 10, 2019 at 7:37 am #3782009

omniP

Preconditions:
- WPML CMS plugin 3.9.1 in use
- WPML Translation management plugin 2.5.0 in use
- WPML String translation plugin 2.7.1
- Customer is using MemoQ application to create translation jobs

Steps to reproduce:
1. Update the plugins:
- WPML CMS to 4.2.5
- WPML Translation Management to 2.8.4
- WPML String translation to 2.10.3
2. After plugins updated try to access WPML => Translation management
==> Needs an update ==> update
3. Try to access WPML => Translation management => Translation jobs

Actuals results:
Cannot see any translation jobs. From the console log, I can see an error:
app.js?ver=5.1.1:1 GET hidden link 404

So it seems that API is unreachable.

Expected results:
API access to work and I could see the translation jobs.

May 10, 2019 at 11:47 am #3783837

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

Did you get the 404 error on Translation Management Dashboard? I want to check this over site access if possible.

For this I would need to request temporary access (WP-Admin and FTP) to your site
– preferably to a test site where the problem has been replicated if possible –
in order to be of better help and check if some configurations might need to be changed

Your next answer will be private which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

✙ Please add the Links to the […] Edit Screen, the Page/Post where you insert the […] and the corresponding Front End Page/Screen.

Best Marcel

May 10, 2019 at 12:42 pm #3784321

omniP

I found the root cause for this. In the theme code there are these filters to change the API prefix from "wp-json" to "api". If I disable those, jobs seem to load ok.

add_filter( 'rest_url_prefix', function () {
    return 'api';
} );

add_filter( 'json_url_prefix', function () {
    return 'api';
} );

Just thinking if WPML has hard coded the API prefix to "wp-json"?

May 10, 2019 at 1:42 pm #3785089

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

I checked the code and yes that's hardcoded:

 $url_prefix = 'wp-json'; 

. This explains the 404 of course.

I see in the <head> that you removed the add_filters already. I spoke with my colleagues and I will escalate this to our 2nd Tier, so please leave the filters for the moment deactivated, until we have a final answer why it was done this way / or solution for you.

Best Marcel

May 10, 2019 at 3:26 pm #3786257

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi again,

I reproduced this now on a clean install and escalated it to our 2nd Tier. I will let you know when I receive an answer from them.

Best Marcel

June 3, 2019 at 12:54 pm #3942379

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

our team confirmed this as a bug. Our developers will solve this in one of the next WPML releases. I will inform you once it's done.

Best Marcel

July 11, 2019 at 10:30 am #4188715

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

please update WPML Core and the String Translation Add-On, then this problem will be done.

Please let me know if it worked for you.

Best Marcel