This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

I Cannot go through a 42% Translation on a gravity form.

Solution:

I went to the error_log file on the admin panel of the website and identified that the max_input_vars were low regarding the requirements of the form that was being saved with translation, so I changed the limit and Voila! It worked!

Relevant Documentation:

https://support.undsgn.com/hc/en-us/articles/213459869-Max-Input-Vars

This topic contains 5 replies, has 2 voices.

Last updated by Itamar 11 months, 4 weeks ago.

Assigned support staff: Itamar.

Author Posts
October 15, 2018 at 2:21 am #2816009

David Fernandez

I am trying to: Translate a gravity form

Link to a page where the issue can be seen: hidden link

I expected to see: 90% of translation when I save and close, I go inside again and 42% of translation shows on the screen, eventhough I have translated most of it. The translation work is no being saved.

Instead, I got: 42% of advance eventhough I have advanced a 90%

October 15, 2018 at 9:38 pm #2818885

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I suspect that you cannot save the Gravity Forms translations because of low WP Memory issue. By looking at the debug info that you have attached I can see that your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.3 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above (this OK with your installation).
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

Could you please perform those procedures and see if it help?

Thanks,
Itamar.

October 16, 2018 at 4:33 pm #2821830

David Fernandez

Hello I have performed this instructions, and it still stays in 42% eventhough I save the translation with a 60%. When I go in again, it is still on 42%. What am I doing wrong?

October 17, 2018 at 9:26 am #2823996

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for trying my suggestions.

I've tested the Gravity Forms plugin on my test site, and I cannot replicate this problem.

I assume that you mark all the 'Translation is complete' checkboxes before you save.

I suspect that there is a collision with the theme or another plugin.
If possible, get your site into a minimum environment.
Minimum environment means switching to a default WordPress theme like Twentyseventeen and no plugins activated but WPML.
Is it possible for you to try it?
You will need first to check if the problem persists when just the theme is switched to Twentyseventeen (for example).
If it persists, then deactivate all plugins except WPML and its add-ons and Gravity Forms itself.
Then please check if the problem persists.
If it does not persists so start by activating the plugins one by one and check when the problem comes back, then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

Thanks,
Itamar.

October 19, 2018 at 1:53 am #2829911

David Fernandez

My issue is resolved now. Thank you! I followed all of the steps you instructed me to do, still it didn´t work. So I went to the error_log file on the admin panel of the website and identified that the max_input_vars were low regarding the requirements of the form that was being saved with translation, so I changed the limit and Voila! it worked!

October 21, 2018 at 8:22 am #2835228

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Great, I'm glad that it is solved now!
Good luck with your web projects 🙂
Itamar.