This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 3 voices.

Last updated by Carlos Rojas 8 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 3, 2019 at 9:10 pm


I am trying to:

Link to a page where the issue can be

I expected to see: a body box like the example I saw on your site

Instead, I got: noting, only the title of the widget

October 4, 2019 at 12:42 pm #4695885


Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)


Thank you for contacting support forum.

As I can see this is not the normal text widget but "enhanced text widget" might be coming from theme or plugin. In this case please follow these options:-

#1 Please ask the author to pass the widget string from correct filters as described here


#2 Use the 2nd method by using String Translation as described here


#3 Use a single widget per language. Ref:

Also, please go to WPML > Support > Debug Information and give me the information in the next reply. You can read the detailed instruction here:


October 4, 2019 at 1:03 pm #4695963

Carlos Rojas

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Thank you for contacting WPML support.

I went to WPML -> Settings -> 'Custom XML Confguration' tab and added the following code:

        <key name="widget_enhancedtextwidget">
            <key name="*" /></key>

Now you can go to WPML -> String Translations and find this strings.

Kind regards,