Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to: invite a translator (hansd-18) that already has a WPML account for another site (www.brickmania.be) to be able to also translate for http://www.belug.be. So in the WPML dashboard I have copied the invitation url and supplied it to hansd-18. However, once he clicks the invitation link and logs in, he only sees the original website http://www.brickmania.be.

Am I doing something wrong or is this a bug?

Solution: What our specialist meant was for you to have a separate organization for your own client (hansd-18, the person with 2 websites). The ticket mentions that 1 website works perfectly (Translator set up and everything).

Our specialists is just asking you to merge your second website to the first one (using steps I have given). Then hansd-18 will have 1 organization with 2 websites.

Relevant Documentation:

This topic contains 14 replies, has 2 voices.

Last updated by Carlos Rojas 3 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 23, 2019 at 10:08 am #4264945

wouterL

I am trying to: invite a translator (hansd-18) that already has a WPML account for another site (www.brickmania.be) to be able to also translate for hidden link. So in the WPML dashboard I have copied the invitation url and supplied it to hansd-18. However, once he clicks the invitation link and logs in, he only sees the original website hidden link.

Am I doing something wrong or is this a bug?

July 23, 2019 at 2:24 pm #4266995

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I'm truly sorry but I don't understand the issue 🙁

Can you please elaborate a little more so I can better understand?

Kind regards,
Carlos

July 23, 2019 at 8:34 pm #4268853

wouterL

Hello Carlos, I will try to describe the problem in more detail...

I have multiple websites. Two of these websites are for the same customer, who uses the same translator. Up to now this translator just had an account on both sites and could translate pages for both sites. However, this means that when he uses the automatic translation this goes from my personal credit. So on the first site I invited the translator to create his own WPML account (using the WPML website). This works perfectly. Now I have created the invitation link for the second site, but when he uses this link, the second site is not added to his profile and wpm and he is using my credits...

Hope this clarifies things...

July 24, 2019 at 12:34 pm #4274371

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your message.

I consulted our specialists about this issue and if you visit this link (https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/merging-and-removing-websites-from-your-advanced-translation-editor-account/) you will find the steps to follow in order to transfer the website to the translator.

Bet regards,
Carlos

July 25, 2019 at 9:19 am #4281251

wouterL

Hello Carlos, When I click the "Advanced Translation Editor Settings" button, I don't get another webpage, but the same settings page is reloaded.

July 25, 2019 at 1:13 pm #4283435

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Please deactivate/activate the Advance Translation Editor and make sure it's activated for your site.

Regards,
Carlos

August 6, 2019 at 5:10 pm #4349699

wouterL

Hello Carlos, sorry for the late reply, I was on holiday.
I tried deactivating and reactivating the advanced translation editor, I even tried removing the WPML license and adding it again, but the result remains the same... Can you help me out?

August 7, 2019 at 10:18 am #4353577

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

August 7, 2019 at 7:36 pm #4357797

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I will consult with our specialists again and I will get back to you as soon as I have an answer.

Thank you very much for your patience an understanding!
Best regards,
Carlos

August 8, 2019 at 10:11 am #4361665

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

According to our specialists you should merge the two organizations.
You can merge two organizations if there is only one website in the source organization (the one you use for code generating).

In this scenario, please use the "Merge accounts" section (below the list of websites).

Steps:
•visit AMS dashboard for source website
•go to Websites
•generate merge code
•open second's website WP dashboard
•visit AMS dashboard for the target website
•paste the code generated in the previous step

Expected result: website, orders, and Machine Translation quota usage should be migrated. No matter which WP website you will use, it will open the same AMS dashboard (with two websites).

Could you confirm that the issue is solved?

Regards,
Carlos

August 8, 2019 at 3:30 pm #4364285

wouterL

I'm sorry, but I don't understand... I don't want to merge organisations, I want to do the opposite: so that my client can use his own translation quota and not use mine.

August 9, 2019 at 10:37 am #4369537

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

What our specialist meant was for you to have a separate organization for your own client (hansd-18, the person with 2 websites). The ticket mentions that 1 website works perfectly (Translator set up and everything).

Our specialists is just asking you to merge your second website to the first one (using steps I have given). Then hansd-18 will have 1 organization with 2 websites.

I hope I explain myself better this time.
Regards,
Carlos

August 16, 2019 at 7:28 am #4405233

wouterL

Thanks Carlos, this has done the trick !

August 16, 2019 at 7:28 am #4405235

wouterL

My issue is resolved now. Thank you!

August 16, 2019 at 11:46 am #4406163

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos