This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.


This topic contains 1 reply, has 2 voices.

Last updated by Itamar 11 months, 4 weeks ago.

Assigned support staff: Itamar.

Author Posts
June 6, 2019 at 12:28 pm


I am trying to: Publish a post (property because my website is a real estate agency) and after finishing all fields, the post publishes as DRAFT and when I click update as: Publish and click the publish button, it keeps saving as draft and never publishes.

Link to a page where the issue can be seen: hidden link

I expected to see: the property published

Instead, I got: draft post

I also contacted my theme support and he said:
"Hi egg_al

I think because your site make a default language is English

Then after install plugin WPML you select language Albanian is main language.

Maybe this make a error.

And problem make by WPML so you can try contact to WPML support.

I think they can help you fix it "

June 6, 2019 at 7:54 pm #3971801


Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)


I've tested things on your site, and I could see the problem. Nevertheless, the problem persisted when I deactivated WPML. Even when WPML was deactivated and I updated the property after filling all the required fields the post status remained in 'Draft'. But then I noticed that there is an 'Action' option on the row of each property when you view all properties. When I press the 'Publish' option (middle option) the property gets published. Please see the attached screenshots. I've tried that on the Albanian properties and the English properties and it works. I wonder how the theme support didn't mention this option to you.
Can you see that this way you can publish a property?

Note: The reality theme By inwavethemes is not officially compatible with WPML. you can see all of our compatible themes here.
Not being on this list does not mean that it is not compatible it just means we do not know yet if it is.

I've also enabled the Translation Management add-on on your site because it is needed when working with WPBakery and most probably also needed to work with your theme.


The topic ‘[Closed] Cannot publish posts, they are saved as draft’ is closed to new replies.