If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by desmondN 1 month, 1 week ago.

Assigned support staff: Mihai Apetrei.

Author Posts
October 7, 2019 at 8:31 am #4705447

desmondN

I am trying to set my homepage as default to hidden link, but it is not working

October 7, 2019 at 9:33 am #4705913

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

October 7, 2019 at 11:17 am #4706523

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for the credentials.

I was able to log in successfully.

From what I can see after I logged in, there's a redirect from "hidden link" to "hidden link".

Can you please elaborate a bit more on what exactly you are trying to accomplish?

Do you want to have this link (hidden link) set to be the homepage link instead of this one (hidden link) ? Did I understand well?

Please let me know.

Kind regards,
Mihai

October 7, 2019 at 1:39 pm #4707897

desmondN

Hi Mihai,

I think I might have found my answer. I just tried this but I removed the checkbox "Use directory for default language", seems be working even for the Malay language.

However, I noticed that language change is not persistent. For example, I have changed my language to Malay. If I go to hidden link and click on any of the "View More", it will bring me to the English results. The search result should return in Malay when I am viewing the listing page.

October 8, 2019 at 10:37 am #4714319

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi.

I am glad to see that the issue was solved.

From what I can see, the "view more" buttons are created with Visual Builder (please check the screenshot below) so you would have to update the link in the translation of the page (for example from "/?select=Eco+%26+Nature&lp_s_loc=51&lp_s_tag=&lp_s_cat=58&s=home&post_type=listing" to "/ms/?select=Eco+%26+Nature&lp_s_loc=51&lp_s_tag=&lp_s_cat=58&s=home&post_type=listing"

Practically, you have to go to the translation of the homepage and update the links to the proper one as the links are added manually not dynamically.

In case you still can't update them, please mark this ticket as resolved and open a new one as due to our support policy, we can only take care of 1 issue per ticket and the initial issue in the ticket is different than the current one.

I hope that you will find the recommended steps above helpful and that you will be able to update the links.

PS: From what I can see, your homepage is not translated yet, so you would need to use the steps below in order to translate it:

- https://wpml.org/documentation/translating-your-contents/page-builders/#translating-page-builder-contents
- https://wpml.org/documentation/plugins-compatibility/how-to-build-multilingual-sites-with-wpbakery-page-builder-and-wpml/

Kind regards,
Mihai

October 8, 2019 at 3:51 pm #4717045

desmondN

My issue is resolved now. Thank you!