Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 3 voices.

Last updated by Andrey 4 years, 6 months ago.

Assigned support staff: Andrey.

Author Posts
April 9, 2015 at 2:23 pm #596646

Neil

I am trying to: view a custom taxonomy

I visited this URL:hornerschool.com

I expected to see: hidden link

Instead, I got: hidden link

April 10, 2015 at 4:57 pm #597455

Ross

Thank you for contacting WPML support, I'd be happy to help!

I see from your screenshots that WPML CMS is not active on your site, it needs to be enabled for WPML to work.

Could you try going to Plugins in your WP-Admin and enabling WPML Sitepress CMS?

Let me know if this works for you!

April 10, 2015 at 5:11 pm #597468

Neil

I had it disabled in the screen grabs to show that the custom taxonomy works without wpml when it's active as it is not I cannot see any custom taxonomies

April 13, 2015 at 1:30 pm #598360

Ross

Thank you for the information and I hope you enjoyed your weekend!

We updated WPML Multilingual CMS and String Translation and the new versions should fix the issue.

https://wpml.org/download/wpml-string-translation/?section=changelog
"April 8, 2015
Fixed a bug related to translating custom post types."

Please let me know if the new versions resolve the issue!

April 13, 2015 at 2:02 pm #598387

Neil

Thanks for the update but I'm still seeing the issue hidden link

April 13, 2015 at 3:16 pm #598463

Ross

Thank you for updating WPML!

I'd like you to try with the Twenty Fourteen Theme and all plugins disabled but WPML and what provides the Custom Taxonomy.

If that doesn't work, please perform a full backup (and be sure to mark "Backup Done: YES) in your reply along with temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

April 14, 2015 at 3:33 pm #599241

Ross

I believe I found the issue, your custom taxonomy isn't set to Translate: hidden link

Now that it has been set, the translated Taxonomies are not displaying under their respective languages.

We have two ways forward, the first would be to restore a backup from before the issue began.

The second would be to go to your wp-config and set define('WP_DEBUG', false); -> define('WP_DEBUG', true); (https://codex.wordpress.org/Debugging_in_WordPress).

I tried connecting to your FTP to enable debugging, however I'm receiving time out errors.

Let me know which works best and what steps you follow!

April 15, 2015 at 9:15 am #599680

Neil

Hi

I've rolled back to 3.1.9.3 and everything looks fine which points to a bug in 3.1.9.5

Can I create a duplicator file so you can troubleshoot?

April 15, 2015 at 3:17 pm #600026

Ross

That would be absolutely fantastic!

I would be happy to file a bug report with our developers, it'll help make WPML the best it can be!

I have enabled the next reply to be private, please upload your snapshot to Dropbox, Google drive, etc and share the link below.

April 23, 2015 at 7:50 am #604562

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+02:00)

Ross has passed your ticket to me. I will try to assist you further.

The link that you gave us has only the database inside the zip package. Can you also provide needed files in order to replicate the issue on local environment.

I set next reply as a private reply so you will able to provide the link.

April 23, 2015 at 7:52 am #604567

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+02:00)

Let me know when you will finish upload them.

April 29, 2015 at 10:52 am #608694

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+02:00)

Thanks for the update.

I am downloading the folder. I'll keep you posted.

May 4, 2015 at 2:11 pm #611348

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+02:00)

We are currently investigating the issue what you have.

I'll let you know once we have any results.

May 25, 2015 at 7:21 am #625152

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+02:00)

Just to update you that we are still investigating the issue you have.

May 27, 2015 at 8:40 am #626797

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+02:00)

Sorry for the delay !

The fix will be included to the next version 3.2 of WPML plugin. I can't give an estimated date yet, but release should be soon.
I have tested your site locally with the development version of plugins and your custom taxonomies are there when WPML plugins active.

I will mark this ticket as resolved, please wait for the next release. In case the issue still persists after update has been done, please open a new ticket.

Thank you for your understanding.