Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: When trying to run the Translation Management Setup, I get an error OTGSUI is not defined and the set up cannot be completed.

Solution: Copying the folder: \sitepress-multilingual-cms\vendor\otgs\ui\dist to the site root folder resolved the issue and allowed the client to complete the setup.

This topic contains 17 replies, has 2 voices.

Last updated by robertZ-5 1 month, 2 weeks ago.

Assigned support staff: Lauren.

Author Posts
September 18, 2019 at 4:40 pm #4599077

robertZ-5

I am trying to:

Set-up the Translation Manager plugin via the backend. However when the page loads nothing appears to work. I can click the check boxes fine, but clicking "Continue" does nothing. In the console there are JavaScript errors occurring which I cannot find the cause for specifically: OTGSUI is not defined.

September 18, 2019 at 5:46 pm #4599361

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

September 18, 2019 at 6:45 pm #4599547

robertZ-5

Any updates?

September 19, 2019 at 12:26 pm #4604675

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thanks for sending credentials. I am able to login, but it looks like my settings are restricted. I don't have access to Plugins, or even WPML Translation Management. Is it possible to make me an admin, or even better yet, can we migrate or make a copy of your site to test? This will allow me to deactivate/activate plugins and themes. I will delete the copy once we have found a solution.

September 19, 2019 at 12:57 pm #4604915

robertZ-5

Sure if that is what will make things easier/faster to hopefully find a solution. 🙂

September 19, 2019 at 1:33 pm #4605367

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Please see my previous private reply and let me know once the migration is completed. Thanks!

September 19, 2019 at 4:35 pm #4607349

robertZ-5

The migration is now completed! Please let me know if you run into any issues with it.

September 20, 2019 at 4:01 pm #4613475

robertZ-5

Just checking in, any new updates?

September 20, 2019 at 4:33 pm #4613595

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I was able to reproduce the issue in the migrated site, so I am checking with our second tier to see if we can determine the cause. I'll update here as soon as I hear back.

September 20, 2019 at 4:35 pm #4613597

robertZ-5

Perfect. Thank you Lauren.

September 23, 2019 at 6:29 pm #4626133

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I was able to resolve this by installing the latest beta versions on the staging site that I had set up. Could you please test this on your live site as well? Be sure to have a backup. You can download the beta versions at http://www.wpml.org/account/downloads and select Beta from the channel drop down.

Please let me know if this resolves the issue.

September 24, 2019 at 2:15 pm #4632381

robertZ-5

Hi Lauren,

I have downloaded and installed the Beta versions of WPML Core, String Translations, and Translation Manager.

When I activate the plug-ins I get this warning on my site: Notice: Undefined index: url in /var/www/web/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/ui/loader.php on line 101

And the Translation Manager page is still having the same issue. I have even tried switching my theme to Twenty Nineteen as you had on the staging site you have set-up on Cloudways.

🙁

September 24, 2019 at 4:22 pm #4633035

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Can you allow me admin access to your staging site so that I can investigate further? I am able to login but my permissions do not allow me to see plugins, or the full WPML menu.

September 24, 2019 at 4:59 pm #4633143

robertZ-5

You should now be able to view the plugins and WPML settings on the staging site. Please let me know if you run into any troubles.

September 24, 2019 at 5:44 pm #4633297

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thanks so much. Please try copying the folder: \sitepress-multilingual-cms\vendor\otgs\ui\dist to the site root folder, then try the Translation Management set up again. Are you able to complete the process?