Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Mateus Getulio 1 month ago.

Assigned support staff: Mateus Getulio.

Author Posts
April 26, 2021 at 1:17 pm #8625339

adelles

I try to translate 2 texts - "Viac" on this page: hidden link
and
"Ďalšie články"
on this page
hidden link

I tried to use string translation search for untranslated text.
But it is not possible to translate this 2 texts

can you help?

April 26, 2021 at 8:47 pm #8629301

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello Adelles,

Welcome to the WPML support forum.

Can you please do the following procedure to try to locate those strings?

- Please go to WPML -> Theme and plugins localization
- Select all plugins in the list and click on "Scan selected plugins for strings"
- When that finishes, select your theme in the other list and click on "Scan selected themes for strings"
- Now go to WPML -> String Translation and search for one of the items you couldn't find to translate and see if it will display now

If that doesn't work, please try to enable the option "Look for strings while pages are rendered" in WPML -> String Translation. Then visit that page in which the widget is located and go back to the String Translation, refresh the page and check if you'll be able to locate the strings now. (Please don't forget to uncheck the option "Look for strings while pages are rendered" once you're done).

Another attempt is to search for those strings in the "Translate texts in admin screens" section of String Translation. To do that, please follow these instructions:

- Go to WPML -> String Translation and click on "Translate texts in admin screens" at the bottom of the page
- Search for one of the items you can't translate
- Select that string and include it in the String Translation
- Go to WPML -> String Translation and search now for that item and see if it will display now for translation

If it doesn't solve the issue, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

April 28, 2021 at 1:43 pm #8645015

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Thanks for the credentials, but unfortunately, we're receiving this message when we open the login page:

"Due to protection of web servers from repeated attacks, we were forced to restrict access to administrative interface of web pages to selected countries. If you are currently in a foreign country, please sign in to WebAdmin, proceed to your domain management and disable this GeoIP filter in CMS section."

Could you please deactivate this feature? Or, if you prefer, here is my IP so you can whitelist it: 201.17.159.161

Once you enable back the login page, kindly give us a heads up on the ticket so we can proceed to the next stages.

Best regards,
Mateus.

May 7, 2021 at 3:58 pm #8715575

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi Adelles,

We tried to access your website again, but so far, we receive the same message. Please check: hidden link

Could you please explain a bit more about how we can enter the admin dashboard? I'm marking your next reply as private in case you need to insert confidential information.

Let us know. Thanks,
Mateus.

May 10, 2021 at 7:04 am #8725735

adelles

try now please

May 10, 2021 at 6:10 pm #8732495

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

It is working now, thank you.

I checked this out but so far I couldn't find a fix for it. I asked my colleagues to have a look at this issue in order to see if there's anything I'm missing.

I'll come back here as soon as one of my colleagues reply back to me (which it shouldn't take long).

Thanks,
Mateus.

May 11, 2021 at 2:01 pm #8740993

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

I have escalated this ticket to our 2nd tier of support where our 2nd tier specialists will take a deeper look at this issue and will try to find a solution.

I will get back to you as soon as I get an answer from them.

Best regards,
Mateus

May 12, 2021 at 4:58 pm #8751061

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Thanks for your patience.

Upon further inspection, our team has concluded that this is a compatibility issue related to how the theme is coded. It needed some modifications in the theme files to fix the problem. We followed these steps:

For the "Viac" string
The string is added on cws_blog_btn_more() at wp-content/themes/orgafit/core/cws_blog.php, LINE 583:

$out .= "<a href='" . esc_url($permalink) . "' class='cws_custom_button'>" . esc_html($more_btn_text) . "</a>";
 

We replaced it with:

 $out .= "<a href='" . esc_url($permalink) . "' class='cws_custom_button'>" . __('Viac', 'orgafit') . "</a>";

For the "Ďalšie články" string

Same issue from the previous string. On wp-content/themes/orgafit/single.php LINE 191, we replaced this line:

echo !empty( $related_projects_section ) ? "<div class='grid_row single_related'>" . "<h3 class='related_news_title'>" . esc_html($related_projects_title) . "</h3>" . $related_projects_section . "</div>" : "";

With this new one:

echo !empty( $related_projects_section ) ? "<div class='grid_row single_related'>" . "<h3 class='related_news_title'>" . __('Ďalšie články', 'orgafit') . "</h3>" . $related_projects_section . "</div>" : "";

After that, we followed these steps for both strings:

- Scanned the theme on WPML -> Theme and plugin Localization
- Went to WPML -> String Translator and searched for the strings
- Switched the language of the strings to the default language
- Translated it into English. Now you can check the translations "More" and "Related Items" on the pages where the strings appear

Could you please verify it and confirm that the issue is fixed? Furthermore, I'd like to ask you to contact your theme support and notify them about this issue.

They can join our Go-Global Program in order to make it fully compatible. We will provide them the guides they might need to make the theme compatible with WPML. We will also provide a WPML account to test the compatibility. Please check more information here: https://wpml.org/documentation/support/go-global-program/

Keep us posted. Thank you,
Mateus.