This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Dennis 5 months, 4 weeks ago.

Assigned support staff: Dennis.

Author Posts
April 23, 2019 at 3:28 am

axeld-7

I am trying to:
Translate a button here "read more"

I followed all the instructions to translate the button, but I keep looking at the button in English,

I have tried to translate with the WPML manager and also with string translation.

Link to a page where the issue can be seen:
hidden link

I expected to see:
Translation of the button,
Instead, I got: button in English 🙁

April 23, 2019 at 9:01 am #3660991

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

I tried to checked the magazine page but for some reason after saving the page the elementor translations were lost.

I sorry for the inconveniences. I have no idea on what went wrong as I was just checking the page. Could you please restore a backup copy of your site?

Also, I would like to ask permission to build a duplicator package so I can continue debugging on my local machine.

Thank you.

Kind regards,
Dennis

April 23, 2019 at 8:52 pm #3667591

axeld-7

I did restore, please don't do that again please 😛

My client almost killed me. I restored the website and please you can download the package, filter the big file you got in warnings(Not needed).

Thank you for your help

April 24, 2019 at 7:43 am #3669859

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply. Sorry again for not being careful.

I have successfully built a duplicator package and I will download a copy and try deploy it on my local machine. Then I will continue debugging your site locally and will give you feedback when I got some results.

Kind regards,
Dennis

April 25, 2019 at 3:51 am #3678713

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for waiting.

I noticed that the custom blog (loop template) is managed by Ele Custom Skin plugin. The issue could be due to compatibility issue with this plugin as this plugin is currently not among on our list compatible/tested plugins. Not being on this list does not mean that it is not compatible it just means that our compatibility team hasn't tested it yet.

https://wpml.org/documentation/plugins-compatibility/

To confirm this, we have to reproduce the issue on a clean install so I have created a test site for you. You can now access it using the link below.

hidden link

Could you please upload your plugin, if possible try to replicate the issue. You do not have to recreate your site, just install the minimum necessary to reproduce the problem.

Please let me know once done so I can go and check. If you have any questions please let us know.

Thank you.

Kind regards,
Dennis

The topic ‘[Closed] Cannot translate button’ is closed to new replies.