This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Carlos Rojas 4 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
June 17, 2019 at 10:53 am #4034647

bennyG

I am trying to translate checkbox value titles in Divi's forms

Link to a page where the issue can be seen:
hidden link

I expected to see:
The 5 checkbox titles (Demande d'information, ...) in the Classic or the Advanced Translation Editor.

Instead, I got: No translation fields for these checkbox titles.

I already tried updating my wpml-config.xml to the one suggested in this thread:
https://wpml.org/forums/topic/cant-find-the-way-to-translate-the-descriptions-of-my-checkboxes-in-divi-contac/
and this one from Github:
hidden link
After the update of the theme's wpml-config.xml file, I clicked Update on the original language page and opened the translation editor again. No change.

June 17, 2019 at 12:46 pm #4035335

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

Could you tell me if you added the XML code in WPML -> Settings -> Custom XML Configuration tab?

If not, please add it and check if the issue persists.

Kind regards,
Carlos

June 17, 2019 at 12:51 pm #4035347

bennyG

I tried that too. At first, it did nothing at all, couldn't even save my code. Got javascript errors, something about vkbeautify. Then I stripped the <wpml-config> tags and it did save, but still no effect. Now that box is empty.

June 17, 2019 at 1:14 pm #4035567

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your message.

It seems there is some kind of conflict with a third party functionality. I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- Add the XML code in WPML -> Settings -> Custom XML Configuration.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Regards,
Carlos

June 17, 2019 at 9:14 pm #4038789

bennyG

I tried what you suggested except going to the Twenty Seventeen theme. That seems pointless as this issue is Divi related. I didn't fix the issue. Still, the fields aren't showing up in the Advanced Translation Editor.

June 18, 2019 at 11:37 am #4043491

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your message.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

June 18, 2019 at 9:47 pm #4046667

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for the information provided.

I took a deeper look at the site and applied some XML configuration but this element is not fully compatible yet with WPML, that's why the options in the checkboxes don''t appear in the Translation Editor.

In this case the recommended way to translate the checkboxes is manually. Just edit the page in the default language (French) -> Change the edit language in the admin menu -> Click on the 'Edit anyway' button -> Ad manually edit the contact form element and translate the checkboxes.

Please let me know if you need further assistance and I will be more than happy to help.
Best regards,
Carlos

June 19, 2019 at 11:17 am #4051045

bennyG

Hi Carlos!

It's a very dirty workaround, but it seems to be working. I had to uncheck 'use WPML translation editor'. Thanks for the help!

greetings,
Benny

June 19, 2019 at 8:22 pm #4054539

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Benny,

As this element is not yet fully compatible with WPML this is the correct way to translate it.

Our developers and compatibility team is working to make all elements compatible but is a progressive work and in each release of the plugin more elements will be in the list of compatible.

Thank you very much for your understanding!
Best regards,
Carlos