Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Slug for a custom post type is translated, however in the front-end the links are still leading to the other (non translated) slug / or the page produces error 404.

Solution: It is always a good idea, first to delete the old slug from WPML -> String Translation. Then you can always go to WPML -> Translation Management -> Multilingual Content Setup -> Custom Posts - and re-translate your slug for the custom post type that you want to have translated.

This topic contains 16 replies, has 3 voices.

Last updated by George Botsev 3 years, 10 months ago.

Assigned support staff: George Botsev.

Author Posts
April 11, 2016 at 8:39 am #857833

francoisB

I am trying to: See the Finnish translation of hidden link

URL of (my) website where problem appears: hidden link

I expected to see: hidden link

Instead, I got: hidden link

Steps to duplicate the issue: go to this link hidden link

Click on the flag to change language to Finnish

All is updated/ upgraded, I tried deactivating all plugins and use wp theme...

I also translated in string translation package to paketti

Basically this happens for ALL the package pages.

April 11, 2016 at 1:57 pm #858268

francoisB

I still need help here.

April 12, 2016 at 7:06 am #858800

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Thank you for contacting WPML support.

#1
Could you please let me know if the translation of this page exists? hidden link

#2
All is updated/ upgraded, I tried deactivating all plugins and use WP theme...
==> Did you notice any changes during performing this steps or is the problem same?

#3
Have you enabled browser redirection from WPML -> Languages -> Browser language redirect? If yes, could you please disable and check if the problem exists?

I will wait for your feedback.

Thanks

April 12, 2016 at 8:53 am #858932

francoisB

Hello Shekhar,

1- yes, the translation is there for months already and was working before upgrade
2- I noticed the problem after the update to WPML plugins
3-yes, browser redirect is disabled

April 12, 2016 at 9:23 am #858966

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues needs some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Thanks

April 12, 2016 at 11:23 am #859126

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Could you please verify your login details once more, as it's not working for me. I have enabled the private reply for you again.

Thanks

April 14, 2016 at 2:39 am #860789

francoisB

Did you get the newl login details?

April 14, 2016 at 5:34 am #860813

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Thank you for the details. I am able to get it.

I can find the problem of package slug not translation on your site, while I try to test it on my local server I couldn't replicate the problem, so In order to debug this issue further, I need to replicate this site on my local server, but due to permissions issue, I could not create a duplicator file, could you please send me a snapshot of your site, you can use a plugin called duplicator and send me the archieve and installer file.

Duplicator instruction
hidden link

I will wait for your feedback.

Thanks

April 14, 2016 at 8:49 am #860941

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Thank you for the details.

Unfortunately, in the ftp you provide their is no any staging folder as well as backup.tar file. could you please check it once.

Thanks

April 14, 2016 at 11:07 am #861084

francoisB

I just double checked with my hosting provider, apparently the settings you have are the correct ones and you should find what you need.

April 14, 2016 at 5:25 pm #861492

francoisB

I still need assistance

April 15, 2016 at 7:16 am #861814

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

In order to be more help, I have escalated this ticket to 2nd tier support, one of the 2nd tier supporter will respond to you soon.

Thanks

April 18, 2016 at 9:30 am #863169

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Hello, I am George from second tier support.
I visited your staging site and reproduced the issue.
Then I went to WPML > String Translation and removed the string for "package" for slug translation.
Then I went to WPML > Translation management > Multilingual content setup > Custom posts and there I added translation "paketti" to your other language, to your slug "package" (In English).
This made the issue go away and now on your staging site everything works just fine.
I
hope that you can reproduce my steps on your main site, and that the problem is not happening for you anymore.

April 18, 2016 at 9:41 am #863188

francoisB

Thank you George,

Just so I don't make a mistake:

When you say " I went to WPML > String Translation and removed the string for "package" for slug translation. " - Did you delete the string?

April 18, 2016 at 9:44 am #863193

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Sorry for not being clear enough there.
Yes - I deleted the string.
When you go and translate it, it will be automatically re-created with the proper translation - no need to worry.