This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.74 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem:

How to add translation support for the 'Mikado' CTA button add-on that extends WPBakery Page Builder?

Solution:

You do it in WPML -> Settings -> Custom XML Configuration (tab). The shortcodes need to be added according to the explanations that we have in our documentation here.
https://wpml.org/documentation/support/language-configuration-files/#page-builder-content

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>mkd_button</tag>
            <attributes>
                <attribute>text</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

Now it is avialable for transaltion in the Translation Editor.

This topic contains 3 replies, has 2 voices.

Last updated by jerryS-5 12 months ago.

Assigned support staff: Itamar.

Author Posts
October 16, 2018 at 3:44 pm #2821657

jerryS-5

I am trying to:
Translate the text on a button. This should be simple...

Link to a page where the issue can be seen:
hidden link -----> you will need to look at the mobile version, so browser width < 460 pixels for the button to show.

I expected to see:
Somewhere in the translation editor or string editor where I can translate the text on the button.

Instead, I got:
Nothing... absolutely nothing, but hours of wasted time searching for how I can possibly make something so simple happen.

October 17, 2018 at 9:18 pm #2825929

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Are you having this issue with the 'Call Now' button?
Please see the attached screenshot.
Is it a regular button or a call to action button?

If you need further help with this, please share the access details to your site with me.
I'm enabling private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

October 21, 2018 at 7:16 pm #2835865

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the access details.

I've fixed the issue with the 'Call Now' button on your site.
Please see the attached screenshot call-now-es.jpg.
You only need to insert the correct Spanish translation for 'Call Now'.

The reason that the button text was not showing for translation is that it is not a built-in element from WPBakery Page Builder. It is some add-on to the WPBakery Page Builder that you have on your site and is called 'Mikado'. This "Mikado' add-on is adding its own elements to the WPBakery, and therefore the shortcodes are different and not recognized by WPML's Translation Editor. Luckily it is possible to add configuration for this in the Custom XML configuration tab.
You do it in WPML -> Settings -> Custom XML Configuration (tab). The shortcodes need to be added according to the explanations that we have in our documentation here.
https://wpml.org/documentation/support/language-configuration-files/#page-builder-content
I've already added the shortcode for the Mikado button like this.

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>mkd_button</tag>
            <attributes>
                <attribute>text</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

Please see the attached screenshot mks-shot.jpg
Now it is avialable for transaltion in the Translation Editor.
If you need to add more Mikado shortcodes, please do it similarly.

Please confirm that the issue is resolved now.

Thanks,
Itamar.

October 22, 2018 at 12:21 pm #2837938

jerryS-5

My issue is resolved now. Thank you!